TODGUB8.DLL missing or corrupt

Posted by: paulnewton54 on 16 September 2017, 8:29 am EST

  • Posted 16 September 2017, 8:29 am EST

    We have been using TDBGrid8 for many years now and have numerous applications worldwide that utilise it.

    We have an installer that was written about 5 years ago that includes TODGUB8.DLL and all the other related files, the problem we have is on one particular XP Pro PC, when we try to show a form that has the grid we get the following error message:

    “DLL module todgub8.dll is missing, corrupt, or incompatible with the current version of True OLE DB Grid 8. DataMode will be set to dgbBound”

    The application is written in VB6 and runs fine on other PCs using the same OS.

    I have tried copying todgub8.dll from my development machine to this machine and re-registering it but to no avail.

    Any help would be appreciated.

    Thanks, Paul Newton

  • Posted 16 September 2017, 8:29 am EST

    Hi ,

    Re-register the TODGUB8.DLL file using regsvr32 close your project and restart it , if the issue still persists then

    Follow the steps below to resolve the issue :

    1. Uninstall the TrueDB Grid.

    2. Search out the ocx/dll files related to the TDBGrid like






    and unregister(using regsvr32 -u) these manually and then delete them.

    1. Reinstall the Tdb grid from the link below and license it.

    (This is the latest build am providing you may use the same as per your license if you already have the setup or the files)

    1. Register the ocx files by using the regsvr32 utility


  • Posted 16 September 2017, 8:29 am EST

    Thanks, registering the latest build files fixed it.


  • Posted 16 September 2017, 8:29 am EST

    I had this issue, and I fixed mine easily - read on…

    I too at first got the “DLL module TODGUB8.DLL is missing, corrupt or incompatible with the current version of True OLE DBGrid 8 . DataMode will be set to dbgBound” error message.

    So I dug up TODGUB8.DLL, placed it correctly, and tried to register it via “regsvr32 todgub8.dll”. No dice - got some registration error message that reg didn’t work.

    Like many folks, I suspected it was due to XArray, but no tweaks involving XArray worked for me.Tried everything - no luck until…

    I found the reg failed because I was running the reg command in a command box that was launched without having chosen “Run as Administrator”.

    Once I opened a command box as administrator and then executed “regsvr32 todgub8.dll”, I at that time got a “succeeded” message. And then when I ran my program there was no more error message.

    All fixed for me. Hope at least some of you are so lucky.

  • Posted 23 April 2018, 7:27 am EST

    I found this post informative.

  • Posted 11 April 2023, 8:09 pm EST

    Hello !!

    Getting missing files you just visit our website and fix your windows related issues within minute.

Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels