Unable to register the DLL/OCX and problems to reach support@componentone.com

Originally Posted 27 April 2010, 5:49 pm EST

  • Originally Posted 27 April 2010, 5:49 pm EST


    I have problems when I try to distribute my application to my customers.
    When they run my setup file (Developed with Inno Setup) they get problems when components are registered. The following error message:

    " Unable to register the DLL/OCX: Regsvr32 failed with exit code 0x3 "

    is shown for the following components (all belonging to True DBInput pro version 8.0.20101.28):
    - tishare8.dll
    - timask8.ocx
    - tidate8.ocx
    - titext8.ocx

    I distribute and install the following components in my setup file:
    - tibase8.dll
    - tishare8.dll
    - timask8.ocx
    - tidate8.ocx
    - titext8.ocx
    All are installed in the system library and I try to register all components except tibase8.dll.

    I have tried to send this issue to support@componentone.com for a week now but I get a delivery failure report every time (see http://helpcentral.componentone.com/CS/forums/p/83049/231850.aspx)


     


  • Reply

    Tomorrow it is 4 weeks (!!!) since I first tried to get this issue to C1 support but I have still not recieved any solution or hardly any reaction at all. And this forum post has still no comments or suggestions.


    My own investigations has led me to this:


    It seems that all components in True DB Input pro must be distributed and registered even if they are not used in the application. I can't get the latest version 8.0.20101.28 to work at all, but in one installation I have succeded with the previous version of the components (8.0.20081.27).


    This is a list of all components in Tru DB Input pro (version 8.0.20081.27) that I now distribute install and register:


    tizonex8.dll


    tishare8.dll


    tiholyx8.dll


    tifincx8.dll


    tidatex8.dll


    ticalcx8.dll


    tibase8.dll


    titime8.ocx


    titext8.ocx


    tinumbl8.ocx


    tinumb8.ocx


    timask8.ocx


    tidate8.ocx


    ticon3d8.ocx


    ticaldr8.ocx


    What do I need more in version 8.0.20101.28 ?

  • Reply

    Hi Bolminge,


    Did you ever get this issue resolved? I'm having the same problem.


    Regards,


    Gregg

  • Reply

    Hi,


    The dlls cannot be registered, and will give you an error if you try. Only register the ocx files, and you should not have any problems.


    -Suelinda

  • Reply

    I have the same problem now when i upgrated to 2010V2 yesterday.


    I can't register titext8.ocx at all 8 clients ,and i has copy tishare8.dll and tibase8.dll to 'c:windowssystem32' .


    This is the err massege ' run time error '339'. Component 'titext8.ocx or one of its dependencies not correctly registered:a file miss or invaild.'

  • Reply

    It's ok today after i remove 2010V2 and re-install 2010V1.


    And it's still raise error in 2010V3.

Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels