Unable to register the DLL/OCX and problems to reach support@componentone.com

Posted by: bolminge on 16 September 2017, 8:23 am EST

  • Posted 16 September 2017, 8:23 am EST

    I have problems when I try to distribute my application to my customers.

    When they run my setup file (Developed with Inno Setup) they get problems when components are registered. The following error message:

    " Unable to register the DLL/OCX: Regsvr32 failed with exit code 0x3 "

    is shown for the following components (all belonging to True DBInput pro version 8.0.20101.28):

    - tishare8.dll

    - timask8.ocx

    - tidate8.ocx

    - titext8.ocx

    I distribute and install the following components in my setup file:

    - tibase8.dll

    - tishare8.dll

    - timask8.ocx

    - tidate8.ocx

    - titext8.ocx

    All are installed in the system library and I try to register all components except tibase8.dll.

    I have tried to send this issue to support@componentone.com for a week now but I get a delivery failure report every time (see http://helpcentral.componentone.com/CS/forums/p/83049/231850.aspx)

  • Posted 16 September 2017, 8:23 am EST

    Tomorrow it is 4 weeks (!!!) since I first tried to get this issue to C1 support but I have still not recieved any solution or hardly any reaction at all. And this forum post has still no comments or suggestions.

    My own investigations has led me to this:

    It seems that all components in True DB Input pro must be distributed and registered even if they are not used in the application. I can't get the latest version 8.0.20101.28 to work at all, but in one installation I have succeded with the previous version of the components (8.0.20081.27).

    This is a list of all components in Tru DB Input pro (version 8.0.20081.27) that I now distribute install and register:
















    What do I need more in version 8.0.20101.28 ?

  • Posted 16 September 2017, 8:23 am EST

    Hi Bolminge,

    Did you ever get this issue resolved? I'm having the same problem.



  • Posted 16 September 2017, 8:23 am EST


    The dlls cannot be registered, and will give you an error if you try. Only register the ocx files, and you should not have any problems.


  • Posted 16 September 2017, 8:23 am EST

    I have the same problem now when i upgrated to 2010V2 yesterday.

    I can't register titext8.ocx at all 8 clients ,and i has copy tishare8.dll and tibase8.dll to 'c:windowssystem32' .

    This is the err massege ' run time error '339'. Component 'titext8.ocx or one of its dependencies not correctly registered:a file miss or invaild.'

  • Posted 16 September 2017, 8:23 am EST

    It's ok today after i remove 2010V2 and re-install 2010V1.

    And it's still raise error in 2010V3.

  • Posted 3 May 2023, 7:06 pm EST

    To register DLL or OCX files use the command regsvr32.

    To deregister DLL or OCX files use the command regsvr32 with the /u switch.

    To register EXE files type the full path and filename and append /regserver.

Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels