Can't Drag & Drop Bound Fields in End User Designer

Posted by: mark on 9 April 2019, 4:17 pm EST

  • Posted 9 April 2019, 4:17 pm EST

    I spent a day creating a custom End User Designer based on the sample End User Designer for v13. Everything works fine except I cannot drag a bound field from the Report Explorer onto the Designer when in Section Reports; I haven't tried the page/rdl. All I get is a square box that appears to be a "nothing". There's nothing to it. I know I did something wrong because the sample project works fine and my v12 code works fine (although very different from v13). I spent the last 5 hours going over everything comparing properties and script between projects and then commenting out script I added but I haven't come up with anything. Before I spend another day re-creating my custom End User Designer, has anyone seen this before?
  • Replied 9 April 2019, 8:03 pm EST

    Hello Mark,

    There must be a problem in the code that's why you faces this issue. Also, it is difficult to narrow down the issue without looking at the actual sample. Is it possible that you can send the running sample to me so that I can replicate the issue at my end and assist you accordingly?

    Thanks.
  • Marked as Answer

    Replied 14 April 2019, 11:45 am EST

    Thanks Mohitg. I attempted to create a small isolated project to demonstrate the issue but experienced too many other issues relating to the corruption of the Designer.vb code (the auto written stuff) corrupting when I changed properties. I think my problem is that I was attempting to use Igor Zavorotny sample VB.NET code/project which I think is buggy as all heck (giving Grapecity the benefit of the doubt). My short-term solution was to revert back to AR12 and then, when I have a day or so to mess around with AR again, I'll attempt to re-create a End User Report Designer from scratch using AR13 controls. I just won't let any of Igor's samples get near my code.
  • Replied 14 April 2019, 9:58 pm EST

    Hello Mark,

    We are sorry for the inconvenience caused to you. I have searched at my end, but can't find any case where Igor shares a sample with you.
    Could you please give the case detail and sample which Igor share with you so that I can navigate the issue further.

    Also, there are a lot of changes in the API of AR from AR12 to AR13. You can find the information about the same at the following link:
    https://help.grapecity.com/activereports/webhelp/AR13/webframe.html#BreakingChanges.html

    Maybe this is the reason which causes the error in Igor sample. Also, you can also share yours End User designer sample of AR13 with so that we can narrow down the issue at our end.

    Thanks.


Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels