I can not upgrade to 15.0.6 via NuGet

Posted by: michael.zhong on 30 March 2021, 8:19 pm EST

  • Posted 30 March 2021, 8:19 pm EST

    I use AR 15.0.2 now, but when I upgrade to 15.0.6 via NuGet, we got the error message what said we no license for 15.0.6. What can we do? Thanks.
  • Marked as Answer

    Replied 31 March 2021, 2:41 pm EST

    Hello,

    I think you have upgraded the "Grapecity.Document.*" related package also. Version 4.* of "Grapecity.Document.*" is not compatible with AR15 that's why you are receiving the error message.

    Please update the ActiveReports related package only not the dependency packages. Actually, the latest version of the dependency packages is not compatible with ActiveReports current version that's why we don't suggest to upgrade them manually.

    Hope it clarifies.

    Thanks,
    Mohit
  • Replied 31 March 2021, 4:28 pm EST

    Thanks, fixed.
  • Replied 7 April 2021, 5:29 am EST

    Mohit,

    I wanted to clarify the statement you made below please. If we install 15.0.2 and start a new project, it will grab particular NuGet packages.

    Are you saying we should not upgrade any (emphasis on any) of the NuGet packages to get the latest fixes? What is the best practice for updating NuGet packages please?

    Thank you.


    mohitg said:
    Hello,

    I think you have upgraded the "Grapecity.Document.*" related package also. Version 4.* of "Grapecity.Document.*" is not compatible with AR15 that's why you are receiving the error message.

    Please update the ActiveReports related package only not the dependency packages. Actually, the latest version of the dependency packages is not compatible with ActiveReports current version that's why we don't suggest to upgrade them manually.

    Hope it clarifies.

    Thanks,
    Mohit
  • Replied 7 April 2021, 2:54 pm EST

    Hello,

    You can update the AR NuGet Packages through the NuGet Manager. However, please don't update dependent NuGet Packages (Like "Grapecity.Document.*") manually. It will be automatically upgrade when you are updating the AR packages.

    Hope it clarifies.

    Thanks,
    Mohit
  • Replied 9 April 2021, 5:03 am EST

    Very helpful, thank you Mohit.
  • Replied 4 May 2021, 3:09 am EST

    mohitg said:

    Version 4.* of "Grapecity.Document.*" is not compatible with AR15


    Related question...
    So AR 14 Uses GC.Document version 4.* and AR 15 uses version 3.*, this is correct?
    My problem is that I am unable to release my program update using AR15 as the Windows Installer will not automatically upgrade a 4.x file to a 3.x file. You would need to manually uninstall the program, and reinstall from scratch, and having several hundred non-technical customers to do that is near impossible.
  • Replied 4 May 2021, 2:29 pm EST

    Hello,

    >>So AR 14 Uses GC.Document version 4.* and AR 15 uses version 3.*, this is correct?
    No, both version uses 3.* version of the GC.Document. You can't use 4.* version of the GC.Document with AR14. It is really strange, that how are you using the AR14 with 4.* version. If you have any stripped down running sample demonstrating the same, can you please share with us.

    Thanks,
    Mohit
  • Replied 5 May 2021, 2:07 am EST

    mohitg said:
    Hello,

    >>So AR 14 Uses GC.Document version 4.* and AR 15 uses version 3.*, this is correct?
    No, both version uses 3.* version of the GC.Document. You can't use 4.* version of the GC.Document with AR14. It is really strange, that how are you using the AR14 with 4.* version. If you have any stripped down running sample demonstrating the same, can you please share with us.

    Thanks,
    Mohit


    This explains all the problems when I initially upgraded/deployed this. I had tried for the first time using the nuget instead of local referenced files. I somehow got it to deploy AR14 with GCDocs 4.x. Its part of a big application, but reporting use is minimal, we do have a problem with exporting as PDF, hence why I have been looking to fix this and upgrade, but the windows installer won't let me deploy 3.x over 4.x without uninstalling, which means us reaching out and manually uninstalling and reinstalling about a thousand customers.
  • Replied 5 May 2021, 2:07 am EST

    mohitg said:
    Hello,

    >>So AR 14 Uses GC.Document version 4.* and AR 15 uses version 3.*, this is correct?
    No, both version uses 3.* version of the GC.Document. You can't use 4.* version of the GC.Document with AR14. It is really strange, that how are you using the AR14 with 4.* version. If you have any stripped down running sample demonstrating the same, can you please share with us.

    Thanks,
    Mohit


    This explains all the problems when I initially upgraded/deployed this. I had tried for the first time using the nuget instead of local referenced files. I somehow got it to deploy AR14 with GCDocs 4.x. Its part of a big application, but reporting use is minimal, we do have a problem with exporting as PDF, hence why I have been looking to fix this and upgrade, but the windows installer won't let me deploy 3.x over 4.x without uninstalling, which means us reaching out and manually uninstalling and reinstalling about a thousand customers.
  • Replied 6 May 2021, 5:15 am EST

    Hello,

    I think, issue get resolved after manually uninstalling and reinstalling software.

    Thanks,
    Mohit
Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels