Invisible / white text in table while page break

Posted by: bernhard.bruns on 10 November 2021, 12:59 am EST

  • Posted 10 November 2021, 12:59 am EST

    Hello, we are using ActiveReports v11 and have some problems while page breaks in tables. As you see in the screenshot, the row P7 ends with the word "Fähigkeiten". But the text is much longer and not visible (but it´s possible to mark). Normally the table breaks to the next page and the rest of the text is also on the next page.

    Can somebody help? 😅

  • Replied 17 November 2021, 2:33 am EST

    Hello,

    Can you please check with AR15 as we do not support the AR11 now?

    Thanks,
    Mohit
  • Replied 7 December 2021, 12:36 am EST

    Hello Mohit,

    we´ve tried version 15.2.4 now and the result is the same:
  • Replied 2 January 2022, 8:06 pm EST

    Hello,

    I was unable to replicate your issue at my end. What type of application is it - Winforms/Webforms/any other?
    Can you provide a sample application with dummy data or make the necessary changes to the attached report and send it back so we can assist you further.

    RegardsEmployee_Table.zip
  • Replied 18 February 2022, 3:30 am EST

    Hello, it´s a winforms application. We tried to make a sampleapplication. In the folder "\ReportTestTool\bin\Debug" are the generated Reports. The problems are comparable but not 100% the same like in the first post.

    For example in document ReportWithErrors_1:
    - Site 13 or 16: The text in the last row ist invisible

    For example in document ReportWithErrors_:
    - Site 2, 3 and 4: The text is overlapping

    ReportTestTool.zip
  • Replied 23 February 2022, 12:51 am EST

    Hi Bernhard,
    Thanks for providing the sample application. I was able to replicate the issues with "ReportsWithError_" on my end.
    The text is overlapping as the Subreport controls are not positioned correctly in the Report "RepEmpfehlungenZurBeseitigungQualitaetsdef.vb". The sub report controls are overlapping the designer which causing them to render above one another. I have made the required changes in the sample attached and attached along with.
    For the issue you have mentioned in your first post I have few questions:

    1. What type of data source are you using?

    2. What is the structure of your data?

    3. What output do you want to generate?

    Please answer the above questions so I can understand your requirement better and help you further on this issue.
    ReportTestTool.zip
  • Marked as Answer

    Replied 28 February 2022, 11:21 pm EST

    Hi Akshay,

    thank you very much. We fixed the overlapping and now everything works fine. Also the issue from the first post.

    Greetings from Germany 👍
Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels