.net 6 Support?

Posted by: chris.eaton on 12 January 2022, 4:52 am EST

  • Posted 12 January 2022, 4:52 am EST

    Hi. Just wondering if .net 6 is supported, and if not, when it will be? Things seem to work just fine in my console applications, but in an ASP.net project I run into issues where the code generators for 6 want to use Microsoft.CodeAnalysis.CSharp >= 4, but GrapeCity.ActiveReports.Core.Scripting requires 3.9.0 specifically, and these are not playing nice.

    At the moment I'm not really sure how to get around this problem.

    Thanks.
  • Marked as Answer

    Replied 12 January 2022, 8:34 pm EST

    Hi Chris,

    ActiveReports 15 does not support .net 6. It will be supported in ActiveReports 16 which is scheduled to be released by mid Jan.
Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels