Problems converting version 8 to 14 with Trial

Posted by: jtengan on 29 September 2020, 5:37 am EST

  • Posted 29 September 2020, 5:37 am EST

    We are migrating our application from vb.net to a web based application using .net core with c#. We were investigating migrating some of our reports from the vb.net project to the .net core project.

    The reports in our vb.net project are in the .vb format. After installing the trial for version 14, we do not see the Reports menu in visual studio (we have tried in several versions of VS, and we have checked under extensions in VS 2019).

    The main reason that I am writing this post is because when we try to use the 'Convert to ActiveReports 14' menu item, the process seems to run for a while then Visual Studio closes without any error message.

    While it is processing it opens up various .vb files in the editor as well as app.config files. It always seems to get hung up on the same file that is actually part of a c# project in our solution (a .cs file).

    I have tried looking int he windows event viewer and the visual studio logs but have not found anything regarding these crashes.

    One thing to note is that the pc that we are testing this on is using a trial version of version 8 as well since we do not want to experiment on our main development machines.
  • Replied 29 September 2020, 5:40 am EST

    One update to add. I just tried it again, and this time, I got a System out of memory exception. After clicking ok, visual studio closed. This is the first time that I have gotten an error message. This was in visual studio 2015 (enterprise). Visual studio automatically reopened after it closed.
  • Replied 30 September 2020, 8:29 pm EST

    Hello,

    I have tried to replicate the same thing at my end but unable to reproduce the issue. It is very helpful if you provide an stripped down sample so that I can able to replicate the issue at my end.

    Thanks,
    Mohit
  • Replied 30 September 2020, 8:29 pm EST

    Hello,

    I have tried to replicate the same thing at my end but unable to reproduce the issue. It is very helpful if you provide an stripped down sample so that I can able to replicate the issue at my end.

    Thanks,
    Mohit
  • Replied 2 October 2020, 10:55 am EST

    In attempting to strip down the solution, it appears that the problem has to do with the large number of projects and reports in our solution. If I remove some projects that have numerous reports, Visual Studio no longer closes without an error.

    I am now able to get to the dialog with the list of files to be affected by the upgrade. However, at the end of the process, I get an error message (image attached):

    The type initializer for 'GrapeCity.ActiveReports.VisualStudio.Internal.*' threw an exception.

    When I click OK on the error message, the dialog closes and references in the projects are still for v8 of active reports. This is in Visual Studio 2017 Enterprise.

  • Replied 4 October 2020, 11:28 pm EST

    Hello,

    Could you please tell how many project and reports in your solution? Also, it is possible to try with the latest installer of AR14:
    http://cdn.grapecity.com/ActiveReports/AR14/Hotfixes/ActiveReports-v14.2.20540.msi

    Also, can you try to convert the application in AR13 first in test machine and see if the issue occur with AR13 also.
    http://cdn.grapecity.com/ActiveReports/AR13/hotfixes/ActiveReports-v13.3.18814.0.msi


    Thanks,
    Mohit
  • Replied 6 October 2020, 5:16 am EST

    Stripped down solution has 29 projects with 161 reports. Original Solution has 46 projects and 172 reports.

    I have tried using the v13 and latest v14 installers that you linked in your post and I still get the error when converting to v14 (converting to v13 worked). I have only tried those in the stripped down solution.

    Thank you for your help.
  • Replied 7 October 2020, 4:33 am EST

    Hello,

    I am discussing with development team (AR-25262) about the error. Meanwhile, could you please try to upgrade the upgraded AR13 project to AR14 and share the result with us.

    Thanks,
    Mohit
  • Marked as Answer

    Replied 8 October 2020, 2:53 am EST

    Hello,

    Can you please uninstalled AR14 on your machine and try with the following installer:
    http://cdn.grapecity.com/ActiveReports/AR14/Hotfixes/ActiveReports-v14.1.20413.msi

    Thanks,
    Mohit
Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels