Table of Contents - works with mouse, and does NOT work with keyboard

Posted by: mlk20 on 23 March 2021, 6:32 am EST

  • Posted 23 March 2021, 6:32 am EST

    Hi,

    Please see attached project and perform the following scenario.
    1. Run the project.
    2. Click Menu->File->Open and open some RDF file e.g. "Catalog.rdf".
    3. Click Menu->File->Add bookmarks.
    4. Click Menu->View->TocView.
    5. In the Table of Contents that is opened click "Document Map" (the second icon on the bottom left).
    6. Click "first page" bookmark using the left mouse button and notice that "first page" tree item is selected and the viewer navigates to the first page of the document (along with the message box).
    7. Click "second page" bookmark using the left mouse button and notice that "second page" tree item is selected and the viewer navigates to the second page of the document (along with the message box).
    8. Click "first page" bookmark using the left mouse button and notice that "first page" tree item is selected and the viewer navigates to the first page of the document (along with the message box).
    9. Click "down arrow" on the keyboard and notice that "second page" tree item is selected BUT the viewer DOES NOT navigate to the second page of the document (message box states that too).
    10. Click "up arrow" on the keyboard and notice that "first page" tree item is selected BUT the viewer navigation again DOES NOT occur (message box states that too).

    This behavior seems to be a BUG in Active Reports because the same action "changing the selected item in the Table Of Contents tree view" has different effect if the selection is done via MOUSE vs KEYBOARD.

    1. Can you please fix it?

    2. Can you provide some solution/workaround how to "handle selection changes via keyboard" so the viewer navigates to the proper page in the same way as it does when the mouse is used?

    Thank you.
    RDFViewer_C#.zip
  • Replied 23 March 2021, 5:03 pm EST

    Hello,

    It is fixed in the latest version of the AR i.e AR15. I suggest you to upgrade to the latest version to get the fix.

    Thanks,
    Mohit
  • Replied 23 March 2021, 6:49 pm EST

    Can you suggest some workaround/solution for AR 11.2 e.g. by using reflection etc...?
  • Replied 24 March 2021, 6:13 pm EST

    Hello,

    Can you please try with 11.3 as I am not able to reproduce the issue with it. Please refer to the attached gif.

    You don't have to purchase the new license for the same. Just install and download the AR11.3 from the following link:
    https://global-cdn.grapecity.com/downloads/activereports/ActiveReports-v11.3.13058.0.msi

    Thanks,
    Mohit
    PageMove.zip
  • Replied 28 March 2021, 9:14 pm EST

    Upgrade of AR is not an option at this moment of the project. We would like to get some workaround for AR 11.2.
  • Replied 30 March 2021, 10:34 pm EST

    Any update?
  • Replied 1 April 2021, 3:26 pm EST

    Hello,

    Sorry, you need to upgrade to the latest version or 11.3 to get the fix of this issue.

    Thanks,
    Mohit
  • Replied 1 April 2021, 3:26 pm EST

    Hello,

    Sorry, you need to upgrade to the latest version or 11.3 to get the fix of this issue.

    Thanks,
    Mohit
Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels