Unable To Add WebViewer To VS Community Edition 2019 Toolbox In WebForms Proj

Posted by: shawn.jackson40 on 16 December 2020, 11:30 pm EST

  • Posted 16 December 2020, 11:30 pm EST

    Greetings - I am unable to add a webviewer tool (or many others) to my toolbox in VS 2019 Community Edition.

    My actual goal for my project is to generate a report and view in a webviewer on my website on an aspx page. However, I can't do that unless I can build it, which, without the above, is impossible.

    I have a legacy webforms .net framework site that I am building on framework 4.7.2.

    I am trying to add dll's and exe's from my installation of ActiveReports 14 that I did locally.

    I tried adding the ActiveReports v15 NuGet packages to my website, and did so successfully, but I am unable to add tools to the toolbos - I tried adding every single DLL in the Nuget package to my project and none of them have any components I am able to add to my project.

    I tried to add also from any dll's from my install directory locally in program files also. I am able to add items to the toolbox that are related to WinForms tools, but that isn't what I want - I need a webviewer for my webforms project.

    Strangely, v15 doesn't seem to exist in any documentation I can find on this site? I can only find v14.

    I notice that the targeted framework in the NuGet repo is 4.6.2. Just of note, even though I have 4.7.2 installed locally, I am unable to make that exact choice in my project pages for my site. However, I go into my web config and set the targeted framework to 4.6.2 by hand. That doesn't work either.

    At one time when I tried to add something to the toolbox related to GrapeCity (I was throwing things at the wall to see what sticks) got a message that components were added to the toolbox, but they won't appear because it is unrelated to my current project. I can't remember what I tried to get that message to appear.

    I have framework 4.7.2 installed on my machine.

    Any help would be bigtime appreciated!

  • Replied 18 December 2020, 4:22 am EST

    Hello,

    AR15 is not official released yet. You can use the AR14 in your sample.

    Please use the following steps:
    1: Create a Web application with higher than 4.6.2 .Net FW
    2: Add the Grapecity.ActiveReports.Web.Viewer NuGet package in your sample
    3: Open the WebForm1.Aspx page in design mode and open the Toolbox of the visualstudio
    4 You find the WebViewer in the toolbox and after that you can drag and drop the viewer in your form page.

    Also, You can refer to the following link to load the report in WebViewer:
    https://www.grapecity.com/activereportsnet/docs/v14/online/activereports-and-the-web.html

    Hope it helps.

    Thanks,
    Mohit
  • Replied 19 December 2020, 10:24 pm EST

    Hi Mohit -

    I tried adding the Web.Viewer NuGet package to both my existing application which is targeting 4.6.2 (which I installed a targeting pack to get to show up) and also a brand new ASP.Net app to test.

    I tried using the last edition of the v14 NuGet package that was released on my existing app that I need to use this on, as well as the first release on my test application.

    No ActiveReports tools showed up in my toolbox.

    Additionally, I tried going to the dll in the packages folder in each app to add them to my toolbox and there were no components found in the dll's. I tried using the 4.6.2 dll for each. I have attached the error message that I see when trying to do so.

    I am currently looking at other reporting solutions as I am unable to get this to work. I will try to do a bit more tinkering but I just need something that will work. Advice is much appreciated.

  • Replied 20 December 2020, 3:25 pm EST

    Hello,

    Can you install the latest version of the AR:
    http://cdn.grapecity.com/ActiveReports/AR14/Hotfixes/ActiveReports-v14.2.20743.msi

    Please try the steps in the newly created Webapplication and request to please confirm if you able to reproduce with newly created application.
    Also, please tell it is web application or WebSite.

    Thanks,
    Mohit
  • Replied 21 December 2020, 4:07 am EST

    Hi Mohit - I installed the msi that you provided. Restarted my computer if anything was in the GAC and not updating in Visual Studio. I included the NuGet Package (14.2.2670) Created a new web application (application, as you have asked). Opened a web form, and tried to find the Web Viewer, and the tool was not in the toolbox.

    I also tried to include items in the toolbox from the NuGet package. I found the NuGet package (GrapeCity.ActiveReports.Web.Viewer.dll) When I tried to import tools from this dll, I get a message that there are no tools in this component.
  • Replied 22 December 2020, 1:25 am EST

    Hello,

    I have checked at my end with same steps and I am not able to replicate the issue at my end. Please refer to the attached image and sample.

    Could you please check with the attached sample.

    Thanks,
    Mohit

    WebApplication5.zip
Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels