Web Designer 2 Bugs

Posted by: kevin.gunn on 8 October 2019, 12:00 am EST

  • Posted 8 October 2019, 12:00 am EST

    After successfully integrating the Web Designer into our application, and extensive use, we have come across 2 bugs that I wish to bring to your attention.

    1. If you click on TextBox in the toolbox, this places it at the position Left: 0, Top 0, or just place a TextBox in this location, you are unable to double click on it to enter the value.

    2. Just adding an empty table to a page, makes the pages duplicate 6 times when previewing.

    Thanks

    Kev
  • Replied 8 October 2019, 6:01 pm EST

    Hello Kevin,

    >>you are unable to double click on it to enter the value.
    I have checked this at my end with Webdesigner sample or when we use WebDesigner in IFrame, However, I am not able to replicate the issue at my end. I think this is issue is related to your sample or occur in a very specific scenario. Could you please explain more so that I can able to reproduce the issue at my end.

    >>Just adding an empty table to a page, makes the pages duplicate 6 times when previewing.
    When you add the empty table, It binds with the dataset by default. Table renders on the report as per data in the dataset. You can try the same after removing the dataset from the report. Also, you can't use the table without the dataset in the report. For every data region control(Table, Tablix, List etc), you must have a dataset in the report.

    Hope it clarifies.

    Thanks,
    Mohit



  • Replied 8 October 2019, 6:25 pm EST

    Hi Mohit,

    I can also reproduce the unable to double click on it to enter the value. in the MVC Example supplied with AR13, sorry I forgot to say that you set the margin on the report to None

    For the Table, I am only providing one set of data for preview.
  • Replied 8 October 2019, 9:10 pm EST

    Hello,

    >>I can also reproduce the unable to double click on it to enter the value. in the MVC Example supplied with AR13, sorry I forgot to say that you set the margin on the report to None
    Thanks for additional information, I am able to replicate the issue at my end and have escalated the same(ARD-768) to our development team.

    >>For the Table, I am only providing one set of data for preview.
    Could you please check after binding any field of the dataset with Table. Is it still rendering in 6 pages with data? Table always render according to record in the dataset. Could you please mentioed how many records present in the dataset. Also, it not recommended to use Table without dataset. You can use the TextBox instead of Table if you do not want to bind with the dataset.

    Thanks,
    Mohit
  • Marked as Answer

    Replied 10 October 2019, 10:21 pm EST

    Hello,

    >>If you click on TextBox in the toolbox, this places it at the position Left: 0, Top 0, or just place a TextBox in this location, you are unable to double click on it to enter the value.
    I am glad to tell you that this issue is fixed in the latest hotfix of AR13 SP2. You can download the same from the following link:
    http://cdn.grapecity.com/ActiveReports/AR13/hotfixes/ActiveReports-v13.2.18593.0.msi

    Thanks,
    Mohit
  • Replied 14 October 2019, 5:43 pm EST

    Great Thanks Mohit,

    I will apply the hot fix and will feedback.

    Kev
Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels