FlexChart not displaying correctly

Posted by: gregor.schiemann on 30 November 2020, 9:51 pm EST

  • Posted 30 November 2020, 9:51 pm EST

    Hello,

    I followed your tutorial for FlexChart in Blazor
    https://www.grapecity.com/blogs/getting-started-with-interactive-blazor-charts
    to the letter. The result looks quite a bit different than the graph on your website - see attachment.

    How can I make this work like expected?

  • Replied 1 December 2020, 6:55 pm EST

    Hi Gregor,

    Can you provide the sample application which you created while following the blog (which replicates your issue)?

    Regards,
    Ashwin
  • Replied 1 December 2020, 10:10 pm EST

    Hi Ashwin,

    Like I said, I followed the instructions on the website to the letter (the APP had no other code). I tried all four versions of the NuGet package, with no noticeable difference. I also tried .Net 5.0 and .Net Core 3.1, same result in both.

    I'm not currently at the PC where I created the test app, but I'm sure you'll be able to replicate your own sample.

    Regards, Gregor
  • Replied 3 December 2020, 4:02 pm EST

    Hi Gregor,

    I tried to replicate your issue by following the instructions from the blog but I was unable to. Please refer to the sample attached. This is the sample that I created while trying to replicate the issue.

    Can you please modify this sample so that it reproduces your issue or provide your sample so that I investigate further?
    Can you also let me know which version of Blazor were you using?

    ~regards

    ChartIntroServer.zip
  • Replied 3 December 2020, 6:53 pm EST

    Hi Ashwin,

    When I run your sample app, I get the same issue.

    The only two graph options which seem to work are Bar and Column. When I change the regional settings of my PC to English US, all chart types are displayed correctly, however, this is not an acceptable option for our target systems. Is there a localization property I'm missing?

    Regards, Gregor
  • Replied 6 December 2020, 3:30 pm EST

    Hi Gregor,

    Can you let me know which region you use by default on your PC?

  • Replied 6 December 2020, 7:19 pm EST

    Hi Ashwin,

    The default (PC) region is sl-SI. I also tried several others and it appears to be broken in every format which uses a comma as a decimal symbol (de-DE, fr-FR, ...). Which would make sense, since it probably displays all decimal values as integers.

    Regards, Gregor
  • Replied 7 December 2020, 5:14 pm EST

    Hi Gregor,

    I was able to replicate the issue with the German region. I have forwarded this to the developers with internal tracking id C1XAMARIN-14136. I will update you once this issue is fixed.

    ~regards
Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels