Text is being cut off at the bottom

Posted by: thomas.hayashi on 15 May 2018, 12:09 am EST

  • Posted 15 May 2018, 12:09 am EST

    I'm using C1Report


    I'm having an error with the text being cut off at the bottom of some pages. Some pages are fine but others have this problem. Not only tables, but also lines.


    I've tried changing those properties CanGrow, CanShrink, Height, KeepTogether, ForcePageBreak and WordWrap on PageFooter and on the Field (Body). None seems to solve the problem.

    The application runs on a 32bits environment and I'm generating a RTF file.

    Looks like the same problem in this thread, but different component
    https://www.grapecity.com/en/forums/ar3-ar6/text-is-being-cut-off-at-t#paginate-1

    Is there any workaround ? Or is it solved in future versions ? Is it related to the app architecture ?
  • Marked as Answer

    Replied 22 May 2018, 7:31 pm EST

    Hi Thomas,

    Can you please try using the latest build of C1Reports and see if that makes any difference? You can donwload the same from the link below:
    http://prerelease.componentone.com/dotnet40/c1winforms/2018-t1/C1WinForms.4_4.0.20181.307.zip

    In case the problem persists, would request you to share a small report demonstrating the same. In addition, please send a sample database to bind with your report. Or, you can use C1Nwind for the purpose.
    This would help me in assisting you further at the earliest.

    Note: C1Report is in maintenance mode and and FlexReport is our flagship reporting tool. Please refer the following link for detailed information on FlexReport:
    https://www.grapecity.com/en/flexreport/

    You can also upgrade your existing C1Reports to FlexReport as mentioned in the documentation here:
    http://help.grapecity.com/componentone/NetHelp/FlexReport/webframe.html#UpgradingC1ReporttoC1FlexReport.html

    Thanks,
    Pragati
  • Replied 7 June 2018, 9:06 am EST

    Hi

    I did not see any testing differences with the suggested version (2018).
    As requested, the test report follows.


  • Replied 7 June 2018, 9:07 am EST

    On page 4 of the report you can see the problem.
    Following file: "Problema_Tabela_Rel.png"


  • Replied 7 June 2018, 9:12 am EST

    Here are the files used in the test with the 2018 version.
    Teste_C1_2018.zip
  • Replied 12 June 2018, 10:26 pm EST

    Hi,

    I am working on this further. Will update you shortly.

    Thanks.
  • Replied 13 June 2018, 9:10 pm EST

    Hi,

    I could observe the issue at my end as well. The text appears to be cut-off from the 4th page in your report. However, the table on this page is directly being fetched from the datasource (which is a xml file). Just sharing as an observation, when I zoom in this report to 200%, the text renders correctly.

    As mentioned above, C1Report is in maintenance mode and and FlexReport is our flagship reporting tool. Hence, I tried loading your report in FlexReportDesigner and the issue no longer exists. Please refer the attached screenshot demonstrating the result in FlexReport at my end.


    I would suggest you to start using FlexReport as it includes a lot more new features and fixes. You can go through more details here:
    https://www.grapecity.com/en/blogs/net-reporting-faster-rendering-and-exporting-with-new-flexreport
    https://www.grapecity.com/en/blogs/introducing-flexreport

    Thanks,
    Pragati
  • Replied 22 June 2018, 5:12 am EST

    Due to the use of the C1Report in several points of the system, it will not be possible to use the FlexReport for now, possibly used in future projects.
    Has it been mentioned that C1Report is under maintenance, does it have any foresight to fix the rendering problem?

    Thanks,

    Renata Ferrari
  • Replied 25 June 2018, 3:41 pm EST

    Hi Renata,

    C1Report is in maintenance mode since last 2 years (after 2016 v1 release), as mentioned here:
    https://www.grapecity.com/en/forums/winforms-edition/c1report-in-maintenance-mo_1

    I am sorry, but the problem cannot be fixed in the old product.

    Thanks,
    Pragati
Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels