License Manager is now popping up 3 times with every build

Posted by: greg.feenstra on 14 September 2020, 7:20 am EST

  • Posted 14 September 2020, 7:20 am EST

    I am using the latest version of NuGets for C1 (v4.1.20202.468), I have been using a generated AppKey within the code. The license and the generated AppKey were working fine, but now I am getting a popup "GrapeCity License Manager" twice for iOS and once for the core project. When I try to "activate" using the serial key, I am unable to press the "activate" button, like the input was not valid. Any ideas on what I'm doing wrong here? I thought we could use code or the generated license files (from the GrapeCity plugin). Didn't think we needed both? Any help is always appreciated!
  • Replied 15 September 2020, 12:44 am EST

    Hi Greg,

    The License Key that you have is of the Old format, to activate it you need to use the old process of the LicenseManager, please refer to the documentation below on how to activate your license.
    https://www.grapecity.com/componentone/docs/license/online-license/xamarin-app.html#i-heading-generate-license-using-grapecity-visual-studio-extension

    please let me know if you need any other help.

    Thanks
  • Replied 15 September 2020, 12:52 am EST

    Hi Abhishek,

    I have tried using the old extension, it actually unloads my projects and now I can't even re-load my projects. I have followed all the documentation (which is confusing as to which one to use by the way) and it has not resolved the issue. I have tried activating the license, but in all cases it does nothing to resolve the issue. When I try to activate through the extension, the button "Activate" is never enabled. This is affecting other developers on this project as well.
  • Replied 15 September 2020, 8:02 am EST

    Another piece of information. I found the folder which contained the ComponentOne Studio Enterprise trial license. I removed that folder, and I was able to compile, build and run just fine. However, when looking at the build output I now see

    EXEC : warning : License for ComponentOne Studio Enterprise is successfully generated. Details: Trial License Activated (30 days left)

    Why does Visual Studio think I have Enterprise? I've not installed it or asked for a trial of it. And more importantly, how to I fix this so it's using OUR license for the Xamarin product?

    Thanks!
  • Replied 16 September 2020, 1:01 am EST

    Hi Greg,

    I have escalated the issue to the concerned team to investigate it further. I will update you as soon as I get any information from them.

    Please let me know if you need any other help.

    Thanks
  • Replied 16 September 2020, 11:34 pm EST

    Hi Greg,


    • If you have your Xamarin key already installed in your machine please run C1LicenseActivation.exe in ProgramData\GrapeCity folder from the command line with argument /gcdetect

    • If not then plese run the C1LicenseActivation.exe in ProgramData\GrapeCity folder.

    • Then use your serial number to activate.



    Please let me know if you need any other help.

    Thanks



  • Replied 18 November 2020, 11:06 pm EST

    I have the same problem, I add the app key in the App constructor.
     C1.Xamarin.Forms.Core.LicenseManager.Key = License.Key;


    In the build output I see that the trial is used to generate the app key?

    License for ComponentOne Studio Enterprise is successfully generated. Details: Trial License Activated (28 days left)


    I verified that in the ComponentOne ControlPanel that the serial is activated.
    How can I fix this, the steps above does nothing, issue still persists.

    Update:
    I try this method https://www.grapecity.com/componentone/docs/license/online-license/xamarin-app.html but I can't login and the Create RunTime License is grayed out.

    Thanks
  • Marked as Answer

    Replied 19 November 2020, 10:28 pm EST

    I Gertjan

    • Can you please try deleting the bin, obj folders of the project try rebuilding it, and confirm if the issue persists?

    • If yes please try creating a small sample with the C1XamairnControl and generate a license key.

    • If the issue persists please share the sample replicating the issue, that will help us to assist you better.


    Please let me know if you need any other help.

    Thanks
  • Replied 23 November 2020, 8:01 pm EST

    Thanks you, now it works!
Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels