Can't go to event DataChanged after download excel file (IE11)

Posted by: duchoapnpd on 5 October 2020, 9:02 pm EST

  • Posted 5 October 2020, 9:02 pm EST

    Hello,
    I have a issue, my web has a spread and button download file excel in header, when I download file excel, I can't go to the event DataChanged in javascript. In browser Chrome and Edge I have not problem, it is just in IE11.
  • Replied 6 October 2020, 8:00 pm EST

    Hi,
    We tried the same with the attached sample and we are unable to replicate the issue at our end with the Spread 13 build.

    Here are the steps:
    Click on Load Excel
    Try to edit a cell
    <Observation> The Data Changed event entry logged in the console.

    Please try at your end and let us know if the issue persists.

    Regards,
    Manish Gupta

    Spread-LoadExcel-DataChanged.zip
  • Replied 6 October 2020, 11:58 pm EST

    Thanks admin, current version of my Spread is 8.0, i downloaded your test project, and it has worked. I test in my project with Spread 13.0, I direct link file Spread.dll and Excel.dll from folder Spread 13 into my project, but it has some error like Fpspread1 is not exist, function PrintInfoExcel() is not work,...
  • Replied 8 October 2020, 12:42 am EST

    Hello,
    For this, please remove all the previous references from the Project and add references for Spread 13. After that delete the bin/obj folder and execute the sample.
    But before that please remember to remove the version information for Spread in the project.

    Regards,
    Manish Gupta
  • Replied 8 October 2020, 2:25 pm EST

    Hi Admin,
    I loaded page, but when I go to, it has this error:

    '/' The application encountered a server error.
    The license for GcListBox was not found. Make sure the licenses.licx file exists in your project and the contents are correct, then rebuild the application.
    Explanation: An unhandled exception occurred while executing the current web request. See the stack trace for more information about the error and where the exception occurred.

    Exception Details: System.ComponentModel.LicenseException: GcListBox license not found. Make sure the licenses.licx file exists in your project and the contents are correct, then rebuild the application.
  • Replied 8 October 2020, 10:39 pm EST

    Hi,
    It seems that the DLL reference for GcListBox has been removed or some entries has been removed from the licenses.licx file.
    Please try after removing the GcListBox from the project or try to replicate the issue with the previously attached project by adding a reference for Spread 8 and 13 versions one by one.

    Regards,
    Manish Gupta
  • Replied 2 December 2020, 6:55 pm EST

    I have a other problem, sorry I don't know why I can't create a new topic, I am using Spread build 8.0, I have a spread with multi column, when I have 20 columns, it is no problem, but when I have 22 columns, it will be out of timeout and freeze button back in IE11, I tested in other browser as chrome, edge and it is ok, it is just have in IE11.
    In my file c# file .cs has function like btnExcel_Click
    FarPoint.Web.Spread.SheetView sheet = new FarPoint.Web.Spread.SheetView();
    CopySheet(FpSpread1.ActiveSheetView, sheet);
    ...............
    var dataex = ExportExcelData(temp, flags);
    if (!string.IsNullOrEmpty(dataex ))
    {
    Session[SESSION_DOWNLOAD_EXCEL] = dataex ;
    string scpt = string.Format(
    "<script type='text/javascript'>insertDownload('DBcmFileDownload.aspx?filename={0}');<" + "/script>",
    System.Web.HttpUtility.UrlEncode(strName));

    ClientScript.RegisterStartupScript(GetType(), "exceldownload", scpt);
    }

    in javascript:
    function insertDownload(urlIn) {
    setTimeout(function () {
    document.getElementById('ifDownloadExcel').contentWindow.location.href = urlIn;
    }, 1500);
    }
  • Replied 3 December 2020, 6:54 pm EST

    Hi,
    We are sorry for the inconvenience, we are unable to replicate the issue at our end. Please refer to the attached sample and modify the sample depicting your issue.

    Regards,
    Manish Gupta

    Spread8Column_20.zip
  • Replied 6 December 2020, 12:38 pm EST

    I see this is not like my project, so I can't attach sample and modify the sample. My issue is the process of excel is out of timeout, and it can't back button in IE11, in chrome and other browser is good.
  • Marked as Answer

    Replied 8 December 2020, 4:27 pm EST

    Hi,
    We are sorry, the shared code snippet is incomplete so we can't test the code at our end. we agree that you may not share your project but if you may modify the attached sample depicting your issue so that we may investigate at our end and assist you accordingly.
    Thank you for your patience.

    Regards,
    Manish Gupta
  • Replied 9 December 2020, 5:16 pm EST

    OK, thank you so much!
Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels