Getting 503 Server Error when Upgrading Spread

Posted by: daniel.ghazvini on 13 October 2021, 7:16 am EST

  • Posted 13 October 2021, 7:16 am EST

    Hello, I am currently working to upgrade a solution for a web application currently using version 8.40.20143.0 of Spread to version 14.45.20214.0.

    The page I am currently trying to test out that contains an embedded Spread Excel form I am able to get working locally after doing the upgrade steps, but I am receiving a 503 Service Unavailable Error when trying to load the page with the embedded Excel form element on a server test environment.

    These are steps that have been taken so far:
    0) Latest version Spread 14.45.20214.0 has been downloaded to local.

    1) Following DLLs have been updated for project solution:
    Previous DLLs:
    FarPoint.CalcEngine, Version=8.35.20143.0
    FarPoint.Excel, Version=8.35.20143.0
    FarPoint.Localization, Version=8.20.20143.0
    FarPoint.PDF, Version=8.35.20143.0
    FarPoint.Web.Chart.Design, Version=8.40.20143.0
    FarPoint.Web.Chart, Version=8.40.20143.0
    FarPoint.Web.Spread.Design, Version=8.40.20143.0
    FarPoint.Web.Spread, Version=8.40.20143.0
    FarPoint.Web.Spread.Extender.dll, Version=8.40.20143.0

    New DLLs:
    FarPoint.CalcEngine, Version=14.45.20214.0
    FarPoint.Excel, Version=14.45.20214.0
    FarPoint.Localization, Version=14.45.20214.0
    FarPoint.PDF, Version=14.45.20214.0
    FarPoint.Web.Chart.Design, Version=14.45.20214.0
    FarPoint.Web.Chart, Version=14.45.20214.0
    FarPoint.Web.Spread.Design, Version=14.45.20214.0
    FarPoint.Web.Spread, Version=14.45.20214.0
    FarPoint.Web.Spread.Extender.dll, Version=14.45.20214.0

    2) Updated Licenses.licx file from Version=8.40.20143.0 to Version=14.45.20214.0

    3) Updated the Web.Config from having the following entries:

    <add assembly="FarPoint.CalcEngine, Version=8.35.20143.0, Culture=neutral, PublicKeyToken=327C3516B1B18457" />
    <add assembly="FarPoint.Excel, Version=8.35.20143.0, Culture=neutral, PublicKeyToken=327C3516B1B18457" />
    <add assembly="FarPoint.PDF, Version=8.35.20143.0, Culture=neutral, PublicKeyToken=327C3516B1B18457" />
    <add assembly="FarPoint.Web.Chart.Design, Version=8.40.20143.0, Culture=neutral, PublicKeyToken=327C3516B1B18457" />
    <add assembly="FarPoint.Web.Chart, Version=8.40.20143.0, Culture=neutral, PublicKeyToken=327C3516B1B18457" />
    <add assembly="FarPoint.Web.Spread.Design, Version=8.40.20143.0, Culture=neutral, PublicKeyToken=327C3516B1B18457" />
    <add assembly="FarPoint.Web.Spread, Version=8.40.20143.0, Culture=neutral, PublicKeyToken=327C3516B1B18457" />

    To these new entries:
    <add assembly="FarPoint.CalcEngine, Version=14.45.20214.0, Culture=neutral, PublicKeyToken=327C3516B1B18457" />
    <add assembly="FarPoint.Excel, Version=14.45.20214.0, Culture=neutral, PublicKeyToken=327C3516B1B18457" />
    <add assembly="FarPoint.PDF, Version=14.45.20214.0, Culture=neutral, PublicKeyToken=327C3516B1B18457" />
    <add assembly="FarPoint.Web.Chart.Design, Version=14.45.20214.0, Culture=neutral, PublicKeyToken=327C3516B1B18457" />
    <add assembly="FarPoint.Web.Chart, Version=14.45.20214.0, Culture=neutral, PublicKeyToken=327C3516B1B18457" />
    <add assembly="FarPoint.Web.Spread.Design, Version=14.45.20214.0, Culture=neutral, PublicKeyToken=327C3516B1B18457" />
    <add assembly="FarPoint.Web.Spread, Version=14.45.20214.0, Culture=neutral, PublicKeyToken=327C3516B1B18457" />

    4) fp_client\fpspread\ directory has been updated from having 8_40_20143_0 to new downloaded 14_45_20214_0 directory.

    Any help in identifying steps that may be missing that would be the cause of this 503 Service Unavailable Error would be appreciated, thank you.
  • Replied 13 October 2021, 8:39 pm EST

    Hi,

    Could you please provide a sample that replicates test the issue so that we could investigate it further and help you accordingly?

    Regards
    Avinash
  • Replied 19 October 2021, 10:05 pm EST

    Hello,
    I have exactly the same problem.
    (I upgrade to trail version 14 to see if everything ok before buying..)
    IIS is crash at all .
    and I have no idea what is the issue .
    daniel, is your problem resolved already ?
    Thanks for any information
  • Replied 20 October 2021, 8:21 pm EST

    Hi Ruth,

    Could you please provide a sample project and the steps by which you are hosting the project on IIS(the steps by which we could replicate the issue) so that we could have a better understanding of the issue and investigation it further?

    Regards,
    Avinash
  • Replied 20 October 2021, 10:26 pm EST

    In a sample project everything is fine.
    The problem is , in existing project which was connect to old old version of FarPoint (v 2.0)
    I removed the old version and installed the version v14.45.20214.0 .
    I added the dll to reference folder . added in web.config, in a form in design time i added the component(added in tool box also), the licenses file added automaticlly .
    What i have to do in the IIS ?
    Im using the trail version to see if it helps our system.
    Thanks
  • Replied 21 October 2021, 9:23 pm EST

    Hi,

    We are sorry but without any sample, it would be difficult to comment on the nature of the issue. Please make sure the fp_client folder is available. Further, if the issue persists please share s sample project for investigation.

    Regards
    Avinash
  • Replied 23 October 2021, 5:27 pm EST

    Hi,
    See , I have a big problem to attach the project with the problem. its the whole VS Solution of my company . its not security at all to attach it here, you agree with me (:
    In a sample project which I created outside the big solution - everything works. its fine.
    So it is very hard to discover what's the problem.
    That's why I ask YOU to let me know what I need to have in the big project .
    I have the fp_client in the IIS , which path it has to be ? the same as the dll in the project ?
    What else can you think about ?

  • Replied 28 October 2021, 5:51 pm EST

    Hi Ruth,

    Could you please declare assembly binding redirect? More details can be found in https://www.grapecity.com/spreadnet/docs/v14/readme/webupgrade.html.

    Further, It's nearly impossible for us to fix the issue by an error number we need a sample for better investigation and I understand providing the whole project here may not be a good idea but you may provide the sample project on our support there, your project solution safe.

    Regards,
    Avinash
Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels