Citrix Server - File Not Found

Posted by: ed-schmerling on 8 September 2017, 4:34 am EST

  • Posted 8 September 2017, 4:34 am EST


    We have successfully built an application using the FarPoint Spread 4 for .Net 3.5.  I have to port it to a Critix Metaframe Server for the users to access the application.  I have copied the application files and installed FarPoint on the new MetaFrame server.  When I run the application, I get the following error:

    System.IO.FileNotFoundException: Could not load file or assembly 'FarPoint.Win.Spread, Version=4.0.3505.2008,
    Culture=netural, PublicKeyToken=327c3516b1b18457' or one of its dependencies.  The system cannot file specified.

    What else is needed on the Citrix server.

     Thanks for any help.

    -- Ed

  • Replied 8 September 2017, 4:34 am EST

    Ed -

    We do not have a Citrix machine to test with.  Does it have a GAC on it?  Is it possible that the application is looking for the dll's in a different location?  Have you tried putting the spread dll's in the same directory as the exe?

  • Replied 8 September 2017, 4:34 am EST


    I do not see GAC on the Citrix MetaFrame server.   I copied all  of the files in the \Program Files\FarPoint Technologies\Spread.WinForms.4.dotNet35\v4.0.3035\bin and placed them into the directory with the application.  It is not pretty, but it worked!


    -- Ed

  • Replied 8 September 2017, 4:34 am EST

    Ed -

    Not sure what you mean by 'not pretty', but I always like to hear that something 'works'!

Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels