clickable area sort indicator issue

Posted by: p.feenstra on 20 July 2021, 6:29 pm EST

  • Posted 20 July 2021, 6:29 pm EST

    The clickable area is not scaled on higher dpi screens.
    Now we can't scale the owner-drawn indicators because then if we click on them, the click action will not always be performed.
    On the attached images the clickable area is indicated with a red line.
    I would really appreciate if this problem could finally be solved.

    Regards Piet

  • Replied 22 July 2021, 12:03 am EST

    Hi Piet,

    Can you please mention how you are drawing custom sort indicators (using PaintSortIndicator method of ColumnHeader renderer or using SortAscending[Descending]Image)? Also, if you've enabled Spread to use High Dpi settings:
    https://www.grapecity.com/spreadnet/docs/v14/online-win/spwin-dpisupport.html

    If possible, please attach a sample application so that we can investigate it.

    Thanks,
    Jitender
  • Replied 22 July 2021, 1:22 am EST

    Jitender,

    I'm inheriting from the FlatColumnHeaderRenderer and override amongst other PaintSortIndicator. I do not use an image.
    The High Dpi Settings are enabled. ZoomDpiSupport on gives the same result.
    The problem is that the rectangle always stays the same.
    R12 suffers from the same.

    You only have to check the rectangle size. (should be easy)

    Regards Piet
  • Replied 22 July 2021, 6:48 pm EST

    Hi Piet,

    How are you using PaintSortIndicator? The rectangle size will remain the same, any changes due to scaling should be handled using the zoomFactor argument of PaintSortIndicator.

    Let me know if I'm missing anything.

    Regards,
    Jitender
  • Replied 22 July 2021, 9:09 pm EST

    Hi Jitender,

    The ZoomFactor works okay but imho dpi scaling is something else.
    The size of the rectangle should be 'zoomfactor * scalefactor'
    Fonts etc. are scaled by dpi but at my end the (clickable) rectangle is not.

    Regards Piet
  • Replied 23 July 2021, 12:18 am EST

    Piet,

    We are discussing this issue with the developers [SPNET-18999]. I'll update this thread once we get some more information on this.

    Regards,
    Jitender
  • Replied 4 January 2022, 5:40 am EST

    Hi Avnish,

    The example you sent works.
    So I've made a new project based on that code and added the most important things from the original project with the issue.
    Even copied the app.config and the manifest file to the new project.
    It all works as expected. But in the original project it does not.
    I narrowed it down to the setting ZoomDpiSupport. It doesn't seem to do anything in my project.
    Can you think of a setting (or missing reference) that causes this behaviour?

    Regards Piet
Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels