enter a value "11:00 AM" it is converted to "11:00"

Posted by: jekin.desai on 18 November 2020, 12:39 am EST

  • Posted 18 November 2020, 12:39 am EST

    When i enter a value "11:00 AM" it is converted to "11:00" and in filter it is showing as 30 Dec 1899.
    How can i stop this behavior. I have not applied any format to cell
  • Replied 18 November 2020, 12:46 am EST

    Also when i try to get the cell value using sheet.getCell(row,column).text(), it returns "11:00"
  • Replied 18 November 2020, 3:36 pm EST

    Hi,
    Any update?
  • Replied 18 November 2020, 10:45 pm EST

    Hi Jekin,

    >>Regarding the 11:00 AM shows as 11:00

    We are able to replicate the issue at or end hence we have forwarded it to the concerned team for further investigation. We will update you regarding this as soon as we get any information. The internal ID for this issue will be SJS-6572.

    >>Regarding date shows in filter Dialog

    The issue has been fixed in our latest 14.0.1 build. Please update to the latest build and let us know if the issue persists for you. You may also download the latest build from here: http://cdn.grapecity.com/spreadjs/14.0.1/Files/SpreadJS.Release.14.0.1.zip

    Regards
    Avinash
  • Replied 19 November 2020, 1:25 am EST

    So i updated to version 14.0.1 using npm and when i ran on local it is showing "Invalid license key". I have key placed already(main.ts) which was working fine with earlier version 13.2.3.
    Any idea?

    PS: I am using angular v10

    Also i did same setup to fix build issue as suggested in
    https://www.grapecity.com/forums/spreadjs/using-spread-sheet-in-angu

    on Replied 26 May 2019, 9:47 pm EST
    i.e. copy the Angular wrapper file to project
    Do i still need to do same after updating to version 14.0.1? or is there any better way because i couldn't find file 'gc.spread.sheets.angular.ts' in 'node_modules/@grapecity/spread-sheets-angular'

    Is there any work around to fix the "11:00 AM" issue maybe temporary fix till concerned team fix and release the new version. Something like setting cell to string type so value is not formatted or disable auto format
  • Marked as Answer

    Replied 19 November 2020, 11:51 pm EST

    Hi Jenkin,

    >>Regarding the workaround
    you may "@" formatter for setting string format to the cells Please refer to the following code snippet and let us know if you face any issues.

    sheet.setFormatter(row,col,"@")


    >>Regarding the License Error

    Spread V13 key will not work in V14. You may remove the license key for testing the component locally also. In Spread V14 we do not need to move any, ts file.

    Further, please confirm if you have any v14 license key to license the v14? Also, please share the email id that is used to purchase the Spread keys so that we may find the key and assist you accordingly.
    Please use our SupportOne portal to ask license-related queries. So please share the email address through the SupportOne portal.

    API References:

    setFormatter: https://www.grapecity.com/spreadjs/docs/v14/online/SpreadJS~GC.Spread.Sheets.Worksheet~setFormatter.html

    Regards
    Avinash
Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels