C1.UWP 'Duplicate Entry' error when building on Visual Studio v15.7.1 and up

Posted by: jeff.gonzaga on 24 May 2018, 3:48 pm EST

  • Posted 24 May 2018, 3:48 pm EST

    I am currently using Library for UWP v10.0.20171.549. When my Visual Studio updated to v15.7.1, I am now unable to build my solution because of the error below. I confirmed that C1 dll's are causing these issue by adding them to a blank Universal project.

  • Replied 24 May 2018, 4:55 pm EST

    UPDATE: I tried updating to your latest version but same result. I am unable to build because of the 2 errors.
  • Replied 24 May 2018, 6:02 pm EST

    I had the same error. Then I deleted C1.UWP.DLL from my project and added the current version again. From this point in time the C1 controls such as C1DateSelector do not display any more.
  • Replied 24 May 2018, 9:09 pm EST


    This is the build error bug that's been reported for VS 2017 15.7.1 here:

    We've seen some reports that 15.7.2 might fix it, but some contradictions to that too. We are still waiting on official word from Microsoft about when and where to expect a fix.

    As of now, you can downgrade VS to solve this problem.

  • Replied 25 May 2018, 12:29 am EST

    Hi Jeff

    We are speaking with Microsoft about this, and they should be taking a look at this over the next week. From what we've seen, the issue effects all thirds party controls, and will need an updated version of VS that corrects the build problem. You can watch the case Pragati provided for updates to this, but right now the safest path is to work in a version prior to 15.7 version of Visual Studio. I'll also update this thread as I get more information.


  • Replied 30 May 2018, 1:55 am EST

    Microsoft has provided a work around for the issue that I was able to get working here. You'll need to Unload your main C# file for this edit:

    In your main app project file, under top-most <PropertyGroup>, add


    There's more info in this case:



  • Replied 2 July 2018, 3:35 am EST

    An update on this, we should have a fix in place for the 2018 v2 release of our UWP controls that will fix this issue and make the workaround unnecessary (presuming you're using at least the 2018 v2 version of the controls). The release is tentatively scheduled for July 18th, and I'll update this thread post release.


  • Marked as Answer

    Replied 19 July 2018, 5:02 am EST

    2018 v2 is available for download and should have the fix. Please let us know if you see any further issues related to this problem with the new version.


Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels