Double Click on Flexigrid is not making disable, Althrough the field is disable

Posted by: kunchakurimounika309 on 9 September 2019, 9:04 pm EST

  • Posted 9 September 2019, 9:04 pm EST

    HI,
    In wijmo flexigrid the disabled field is enabled when double click and If I use the tab key to advance through all the fields are disable

    <wj-flex-grid-cell-template cell-type="Cell">
    <wj-input-number
    value="$item.Value"
    format="c2"
    min="0"
    ng-disabled="$item.Value"
    >
    </wj-input-number>
    </wj-flex-grid-cell-template>
  • Replied 10 September 2019, 4:19 pm EST

    Hi,

    As per my understanding, when you are double-clicking on this column, the column becomes editable and wish to avoid this behavior. You may avoid this by setting the isReadOnly property of the column to true. Refer to the sample below:

    https://jsfiddle.net/jeqw6och/

    Let me know if this is your requirement. And if it is not, then could you please update the sample accordingly.

    Regards,
    Ashwin
Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels