FlexGrid scroll unsynchronized IE and Safari

Originally Posted 31 January 2016, 10:35 pm EST

  • Originally Posted 31 January 2016, 10:35 pm EST

    We have seen on large grids specially with many columns that the row selector and actual row cells become un-synchronized when scrolling on both IE and Safari, we have been unable to detect this issue with Google Chrome.

    I have attached a video showing it on Internet Explorer, this is a grid with a single column having this issue, the issue becomes worse and worse the more columns are displayed.

    I have also attached the JSFiddle used to create this video.

    http://jsfiddle.net/w0zg3v2x/4/
    2016/02/2016-02-01_12-25-42.mp4
  • Reply

    Hello,

    Thank you for providing the sample fiddle and the video depicting your issue. I have escalated the issue to the concerned team. I will let you know as soon as I get any information in this regard.

    Thanks,
    Manpreet Kaur
  • Reply

    Hello I am facing a simular issue here on the latest version of Safari (14.1 (15611.1.21.161.5, 15611)).
    The headers of the grid is not in sync with the content, sometimes the grid remains blank (or parts of it) until the user clicks on the grid too.
    The issue is happening even in the demo pages of wijmo.
    https://www.grapecity.com/wijmo/demos/Grid/Overview/vue.
    There is a video attached that demonstrates the problem on this page.

    Thanks in any advance.

    Safari Scroll Issue.zip
  • Reply

    Hi Eduardo,

    I can observe your issue in the video but I am afraid I was unable to replicate it at my end. You can refer to the video link below:

    https://www.dropbox.com/s/ubnfp1bsbde65ku/Untitled.mov.zip?dl=0

    And this is the device that I used:
    Device: MacBook Pro
    OS: macOS Big Sur
    Safari: 14.1

    Can you please let us know your exact device which you are using so that I can test it?

    Regards,
    Ashwin
  • Reply

    Hi ashwin,

    We experienced the issue on these devices described on the images below. They are both Mac minis, one with macOS Catalina and the other one is with Big Sur.



  • Reply

    Hi Eduardo,

    Thank you for providing the device info. I will test them on these devices and will update you accordigly.
    In the meantime, can you check whether only this demo causes this issue or even a simple FlexGrid causes it?

    ~regards
  • Reply

    Hi Eduardo,

    I wasn't able to replicate the issue in the provided device also. This was the device which I used:



    But I have enquired about this issue with the dev team. Maybe they will be able to replicate it or provide some workaround. The internal id of the case is WJM-20030.

    I will update you once I will hear from them.

    ~regards
Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels