Wijmo Angular 8 to Angular 9 migration issue

Posted by: reeshabh.choudhary on 9 February 2020, 8:23 pm EST

  • Posted 9 February 2020, 8:23 pm EST

    Attaching the build errors getting while migrating my projects fron Angular 8 to Angular 9. I have also upgraded my wijmo version from "5.20192.624" to "5.20193.637".

  • Replied 10 February 2020, 4:29 pm EST

    Hi Reeshabh,

    We are sorry but we were unable to replicate the issue at our end. We created an Angular9 application and built it using ng build command. The build was completed without any errors.
    Please refer to the sample attached.

    Regards,
    Ashwin

    wijmo-angular9.zip
  • Replied 10 February 2020, 5:02 pm EST

    In my package.json, I have declared
    "wijmo": "^5.20193.637",


    Is this correct way? since, I see, you guys have declared like:
     "@grapecity/wijmo.angular2.all": "^5.20193.637",
  • Replied 10 February 2020, 5:16 pm EST

    Nope, tried above change, did not work. Is because Ivy is enabled by default in new Angular App?
  • Replied 10 February 2020, 5:30 pm EST

    I tried by using
    "angularCompilerOptions": {
    "enableIvy": false
    },

    and it builds. So, the current version is not for Angular Ivy Engine?
  • Replied 11 February 2020, 4:25 pm EST

    Hi Reeshabh,

    Wijmo is compatible with Angular Ivy but there is an issue in the non-scoped wijmo npm package ("wijmo": "^5.20193.637"). We have forwarded this issue to the dev team with internal tracking id 420735.
    As a workaround, we would suggest that you use the scoped npm package ("@grapecity/wijmo.all": "^5.20193.637"). After installing this package, you will need to update your project to use this package instead of wijmo. Please follow the blog below that shows how you can easily update the package:

    https://www.grapecity.com/blogs/wijmo-npm-package-changes

    ~regards
  • Replied 13 February 2020, 6:18 pm EST

    I did the changes as suggested, now I am getting a label, wijmo is in Evaluation version, however, I have kept the same license key in my project.
  • Replied 13 February 2020, 6:26 pm EST

    Wijmo Financial excel sheet is not working as per existing functionality. Attaching screenshot of error getting in console.

    Basically, it is not able to perform arithmetic operation on grid cells, which were working perfectly in previous version.
  • Replied 13 February 2020, 6:27 pm EST

  • Replied 13 February 2020, 6:32 pm EST

    In short, wijmo flexsheet operations are not working at all.
  • Replied 16 February 2020, 4:39 pm EST

    Hi Reeshabh,

    Regarding the license, it may be possible that your license is valid up to the 19v2 version only. Could you please send us the screenshot of the Wijmo license splash screen, if it is displayed?

    Regarding the FlexSheet, could you please let us know when exactly the error occurs and the exact steps for replicating the issue? Also, it would be really helpful if you could provide us with a small sample replicating the issue.

    ~regards
  • Replied 17 February 2020, 8:43 pm EST

    Wijmo version issue:
  • Replied 17 February 2020, 9:06 pm EST

    In Flexsheet, I have the following code:
    onFlexSheetInit(flexSheet: wjcGridSheet.FlexSheet) {
    const self = this;
    flexSheet.deferUpdate(() => {
    flexSheet.itemsSource = self.itemSourceObj.dataSource;
    flexSheet.columnLayout = JSON.stringify({ columns: self.itemSourceObj.columnLayout });
    flexSheet.columns[0].width = '*';
    flexSheet.columns[0].minWidth = 350;
    flexSheet.rows[0].wordWrap = true;
    flexSheet.columns.defaultSize = 125;
    // flexSheet.scrollTo(0, 0);
    flexSheet.autoSizeRows();
    flexSheet.itemFormatter = (panel, r, c, cell) => {
    cell.style.borderLeft = '';
    if (panel.cellType === 1 && (r === 0 || c === 0)) {
    // self.setHeaderStyle(cell, c, r, headerColRange);
    self.handleReadOnlyFields(r, c, cell);
    } else if (panel.cellType === 1) {
    self.getSetEvaluatedCellValue(r, c);
    self.handleCalculatedFields(self.itemSourceObj.dataSource, r, c);
    self.handleReadOnlyFields(r, c, cell);
    self.handleCellDataType(self.itemSourceObj.dataSource, r, c, cell);
    }
    };
    });
    }


    In earlier version, it used to check on every row and column of my flexsheet, i.e. basically every cell and update the values accordingly on editing one cell, however, in the new version, this is not happening on edit.
  • Replied 18 February 2020, 5:41 pm EST

    Hi,

    Regarding the license, as written in the license popup, your license is for 18v2 version which is only valid up to 19v2 (after 1 year of purchase). In order to utilize the 19v3 version, you will need to upgrade your license. To upgrade the license, you can contact the sales team at us.sales@grapecity.com.

    Regarding flexsheet issue, as per our understanding, the cells containing formulas are not updated after a cell is edited. We tried to replicate the issue at our end but we were unable to do so. Please refer to the sample link below that we used to replicate the issue:

    https://stackblitz.com/edit/angular-tcqvvu

    Can you please modify the sample so that it replicates the issue?

    ~regards
Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels