wijmo library under angular 12 can not be loaded

Posted by: Meirav.Eliad on 3 February 2022, 4:06 am EST

  • Posted 3 February 2022, 4:06 am EST

    in my package.json I defined
    "wijmo": "^5.20213.834",

    when I run ng serve i get the follwing error

    Error: node_modules/wijmo/wijmo.angular2.input.d.ts:2626:22 - error NG6002: Appears in the NgModule.imports of ShellModule, but could not be resolved to an NgModule class.

    This likely means that the library (wijmo/wijmo.angular2.input) which declares WjInputModule has not been processed correctly by ngcc, or is not compatible with Angular Ivy. Che
    ck if a newer version of the library is available, and update if so. Also consider checking with the library's authors to see if the library is expected to be compatible with Iv
    y.

    2626 export declare class WjInputModule {
    ~~~~~~~~~~~~~





    what should I do?
  • Replied 3 February 2022, 10:52 pm EST

    Hello,

    We apologize but we are unable to replicate the issue at our end, could you please have a look at the sample attached below and let us know if we are missing something to replicate the issue.

    If there is any additional information or steps to replicate the issue then please let us know that as well.

    Sample:Angular12.zip

    Regards
    Sonu Kumar Pandey
  • Replied 5 February 2022, 5:08 am EST

    attached is a file that show the problem.
    just run ng serve
  • Replied 5 February 2022, 6:11 am EST

    run
    npm install
    ng serve
    test-wijmo.zip
  • Replied 5 February 2022, 10:19 pm EST

    in projects/common there are 2 sub-entries.
    if you remove the bread-crumb it will work.
    note that bread-crumb is actually empty
  • Marked as Answer

    Replied 6 February 2022, 11:52 pm EST

    Hello,

    The issue was occured because you were using the old no-scoped wijmo packages with the latest build. You need to install scoped wijmo packages as after wijmo build 5.2018X.XXX the "wijmo": "^5.20213.834" are referred to as non-scoped packages and you would be required to use "@grapecity/wijmo.angular2.all": "^5.20213.824". For more information please refer to the Doc link below:

    https://www.grapecity.com/wijmo/docs/GettingStarted/Referencing-Wijmo-NPM

    You may also refer to the updated attached sample demonstrating the same: Wijmo_input.zip

    Regards
  • Replied 7 February 2022, 3:43 am EST

    thank you, the library has been build.
    But I think I should use lower version.
    I need a version that support umd files.
    probably for angular 12.
    what version should I use for angular 12?
  • Replied 7 February 2022, 4:50 am EST

    thank you I found it everything is ok now
  • Replied 7 February 2022, 3:11 pm EST

    Hello,

    We are glad that you were able to resolve your issue. Thank you for sharing.

    Regards
Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels