Add super label to flex report

Posted by: haim on 5 April 2021, 6:29 pm EST

  • Posted 5 April 2021, 6:29 pm EST

    I would like to add a super label to a flex report. The documentation states:
    "For registering a custom field, say MyField, add your control to the <customfields> section in the C1FlexReportDesigner.4.exe.settings file as follows:
    <customfields>
    <item value="C1.Win.FlexReport.CustomFields;C1.Win.FlexReport.CustomFields.SuperLabel" />
    <item value="C1.Win.FlexReport.CustomFields;C1.Win.FlexReport.CustomFields.Map" />
    </customfields>"
    I can't find a ...settings file. There is a ...config file but when I add the xml to the config file I get an error when opening the designer.
  • Replied 6 April 2021, 4:03 pm EST

    Hi,

    You can find the settings file and the designer located at "C:\Program Files (x86)\ComponentOne\Apps\v4.0". Then you can follow the steps as mentioned at https://www.grapecity.com/componentone/docs/win/online-flexreport/AddingFlexReportCustomFields.html to add the entries in the setting file. Now when you will open the C1FlexReportDesigner.4 located at the same location, you will be able to use Custom Fields that you added.
    If you are using the C1FlexReportDesigner.4.5.2, we are getting in touch with the development team to get information regarding it and will let you know when we have an update.

    Regards.
    Avnish

    [Internal Tracking ID: C1WIN-24700]
  • Replied 6 April 2021, 9:20 pm EST

    So at present I cannot add a super label to a FlexReport in version 4.5.2?
  • Replied 6 April 2021, 9:38 pm EST

    Hi,

    As per the developers, you can find the setting file for the C1FlexReportDesigner.4.5.2 at C:\Users\UserName\AppData\Roaming\C1Report. You then need to add the following code to the corresponding settings file and you will be able to use CustomFields in C1FlexReportDesigner.4.5.2:
    <customfields>
    <item value="C1.Win.FlexReport.CustomFields.4.5.2;C1.Win.FlexReport.CustomFields.SuperLabel" />
    <item value="C1.Win.FlexReport.CustomFields.4.5.2;C1.Win.FlexReport.CustomFields.Map" />
    </customfields>


    Please note that even if you don't have this code set up in the setting file, the C1FlexReportDesigner.4.5.2 App can still successfully open reports with SuperLabel Fields.

    Regards.
    Avnish
  • Replied 7 April 2021, 5:15 pm EST

    Thank you for the help. I was able to add the super label but now I cannot display a field from my database in the label. I set the text property of the field in the designer to =databasefield or the field name without the '=' and the field only displays the characters I entered into the property value.
  • Replied 8 April 2021, 3:34 pm EST

    Hi,

    If you want to bind a SuperLabel field to a field of the database then you first need to set the Calculated property of the field to true and then you can set the Text property to the name of the field of the DB. Please refer to the sample attached.

    Regards.
    Avnish
    SuperLabelBind.zip
Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels