C1FlexReport need click to [Parameter Apply] button in first load?

Posted by: tri.nguyen on 14 December 2020, 1:06 pm EST

  • Posted 14 December 2020, 1:06 pm EST

    Hi All,

    When I am load C1FlexReport to C1FlexViewer.DocumentSource the Viewer shows up [Report Parameter ] region with forcing me to click in [Apply Parameter] Button, just after that it will show up the report template.

    How can I make those parameters be applied by default right after I assign a report to DocumentSoruce?
  • Replied 15 December 2020, 8:35 pm EST

    Hi Cao,

    You can set the Hidden property of the parameter class to True if you want to hide the user interface when working with parameters.
    https://www.grapecity.com/componentone/docs/wpf/online-flexreport/C1.WPF.Document.4.5.2~C1.WPF.Document.Parameter~Hidden.html?highlight=hidden%2C

    If you are still facing the issue then I request you to please share your report with dummy data so that we can assist you better.

    Regards,
    Prabhat Sharma.
  • Replied 20 December 2020, 2:59 pm EST

    prabhat.sharma said:
    Hi Cao,

    You can set the Hidden property of the parameter class to True if you want to hide the user interface when working with parameters.
    https://www.grapecity.com/componentone/docs/wpf/online-flexreport/C1.WPF.Document.4.5.2~C1.WPF.Document.Parameter~Hidden.html?highlight=hidden%2C

    If you are still facing the issue then I request you to please share your report with dummy data so that we can assist you better.

    Regards,
    Prabhat Sharma.


    Hi, How can I create dummy data from my Report?
  • Replied 20 December 2020, 9:02 pm EST

    Hi Cao,

    You can share the .mdb or excel file containing the dummy entries of each field used in the report that is bound with the data source.

    Regards,
    Prabhat Sharma.
Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels