Date time control IME disable

Posted by: mayur.purandare on 6 August 2020, 9:06 pm EST

  • Posted 6 August 2020, 9:06 pm EST

    Dear Team,

    In my application, i want disable IME fro all textboxes and controls.

    I have set following property for text box and it works correctly.
    InputMethod.IsInputMethodEnabled="False"

    I have used same property for Date time controls, but it is not working properly.
    I am able to copy other characters in this control.
    Please let me know if anything needs to be done except setting this property.
  • Marked as Answer

    Replied 9 August 2020, 6:38 pm EST

    Hi Mayur,

    I have tried the same with C1DateTimePicker, C1DatePicker and C1TimeEditor and it is working fine at my end as IME gets disabled after setting this property. I have tested it with Windows 10 64 bit, Microsoft IME (Japanese input) and control version 4.5.20202.716, 4.5.20201.697.

    Can you please confirm which IME you are using along with the control version?
    And also if possible can you please provide a stripped down sample along with specific steps (if any) replicating this issue.

    Regards,
    Basant
  • Replied 13 August 2020, 6:02 pm EST

    Yes.
    IME is disabled in my case also.
    But I am able to paste kanji characters in date control box.
Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels