.NET 5 and C1 version 4.5.2 controls?

Posted by: rileydylanrd303 on 18 January 2021, 10:01 pm EST

  • Posted 18 January 2021, 10:01 pm EST

    Can I use C1FlexViewer, C1FlexReport and C1XLBook in a new .NET 5 WPF project if I use the 4.5.2 controls? Can I use both C1 4.5.2 controls and C1 5.0 controls in the same project? Thanks.
  • Marked as Answer

    Replied 19 January 2021, 5:01 pm EST

    Hi Riley,

    1) Yes, you can use .NET 4.5.2 C1 controls in a .NET 5 WPF project.

    2) We are sorry but it is not possible to use two different versions of the same control in the same project as it will cause conflict because of the similar API.

    I hope it helped.

    Regards,
    Kartik
  • Replied 20 January 2021, 5:45 pm EST

    rileydylanrd303 said:
    Can I use C1FlexViewer, C1FlexReport and C1XLBook in a new .NET 5 WPF https://xender.vip/ https://omegle.onl/ project if I use the 4.5.2 controls? Can I use both C1 4.5.2 controls and C1 5.0 controls in the same project? Thanks.
  • Replied 20 January 2021, 6:53 pm EST

    Hi Riley,

    Your questions were answered here. Is there something else you'd like to ask?

    Regards
  • Replied 16 February 2021, 6:54 pm EST

    Does the end user need to have .NET Framework installed for .NET 4.5.2 C1 controls in a .NET 5 WPF project to be used?


    .NET 5 project:
    https://essaydune.com report
  • Replied 16 February 2021, 11:07 pm EST

    Hi Cori,

    Yes, you need to have .NET 4.5.2 framework installed on the system while using C1 4.5.2 controls in a .NET 5 project.

    Best Regards,
    Kartik
Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels