Xuni Components Native Linking Error

Posted by: chethan.k on 26 July 2018, 8:53 pm EST

  • Posted 26 July 2018, 8:53 pm EST

    I am using a licenced Xuni components for Xamarin IOS Project.I am unable to take Release build for Iphone.The errors I am getting is of the type below:

    error MT5209: Error: warning: object file (/obj/iPhone/Release/mtouch-cache/libXuniInput.a(XuniComboBoxHeaderView.o)) was built for newer iOS version (9.2) than being linked (9.0) Native linking



    MT5209: Error: warning: object file (/obj/iPhone/Release/mtouch-cache/libXuniInput.a(XuniAutoCompleteHeaderView.o)) was built for newer iOS version (9.2) than being linked (9.0) Native linking


    MT5209: Error: warning: object file (/obj/iPhone/Release/mtouch-cache/libXuniInput.a(DropDownHeaderView.o)) was built for newer iOS version (9.2) than being linked (9.0) Native linking



    MT5209: Error: warning: object file (obj/iPhone/Release/mtouch-cache/libXuniInput.a(XuniAutoCompleteEventArgs.o)) was built for newer iOS version (9.2) than being linked (9.0) Native linking



    error MT5209: Error: warning: object file (/obj/iPhone/Release/mtouch-cache/libXuniInput.a(DropDownView.o)) was built for newer iOS version (9.2) than being linked (9.0) Native linking



    error MT5209: Error: warning: object file (/obj/iPhone/Release/mtouch-cache/libXuniInput.a(XuniComboBoxDropdownView.o)) was built for newer iOS version (9.2) than being linked (9.0) Native linking



    Error MT5212: Native linking failed, duplicate symbol: '_OBJC_CLASS_$_XuniEaseAction'. (MT5212)



    Error MT5213: Duplicate symbol in: /obj/iPhone/Release/mtouch-cache/arm64/registrar.o (Location related to previous error) (MT5213)





    The Software used :
    macOS High Sierra-10.13.3
    Visual Studio Community 2017-Version 7.5.4 (build 3)
    Xcode-9.3.1 and 9.2
    <package id="Xuni.iOS.Calendar" version="2.3.20163.160" targetFramework="xamarinios10" />
    <package id="Xuni.iOS.ChartCore" version="2.3.20163.160" targetFramework="xamarinios10" />

    <package id="Xuni.iOS.Core" version="2.3.20163.160" targetFramework="xamarinios10" />

    <package id="Xuni.iOS.FlexChart" version="2.3.20163.160" targetFramework="xamarinios10" />

    <package id="Xuni.iOS.Input" version="2.3.20163.160" targetFramework="xamarinios10" />



    Kindly help me to fix this Error

Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels