FlexGrid cell edit and virtual keyboard

Posted by: arodko on 8 August 2017, 1:40 am EST

  • Posted 8 August 2017, 1:40 am EST

    I see from the demos that FlexGrid will automatically scroll when editing so that virtual keyboard doesn't cover up the cell. This isn't working for my project though as the FlexGrid does not scroll enough. I'm assuming that this is because I have a Toolbar and Tab Bar Controller at the bottom of my screen. Would there be any configuration adjustments I could make to make it work with this setup? I tried extending the FlexGrid to the bottom of the screen (underneath the toolbars), but that didn't make a difference.
  • Replied 8 August 2017, 1:40 am EST

    Hello

    Sorry for the delay on this, but I've been unable to reproduce this on my end. Whatever cell is being edited always scrolls into view above the keyboard in the various layouts I've made. I'm guessing that there's some specific combination of configuration options that's causing it in your project. One possible suggestion might be to use the scrollIntoViewMethod to force the cell into view if it's otherwise obscured. You could probably use this in tandem with beginningEdit (which is part of the FlexGridDelegate) so that you could track when a cell goes into edit mode. Something along those lines should work. If you're still having trouble please submit a sample that reproduces it so that we can take a look.
  • Replied 8 August 2017, 1:40 am EST

    Thanks. Although scrollIntoView does scroll, it scrolls to just below the edge of the keyboard. I'll see if I can put together a simple sample that reproduces it, but for now what I did to get it to work was to to offset the entire view up above the keyboard if the keyboard will cover the row. Thanks again!
Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels