Spread Windows Forms 13.0 Product Documentation
Spread Windows Forms 13.0 Product Documentation / Spread Designer Guide / Spread Designer User Interface / Spread Designer Menus / File Menu
In This Topic
    File Menu
    In This Topic

    The File menu generally has operations, such as opening or saving a file, and printing. You can also reset the spreadsheet to default settings and preview the spreadsheet from this menu. From here, you can apply changes to the spreadsheet or revert to the settings when it was originally loaded. For information on reverting to previous settings, refer to Resetting and Clearing Design Work. If you select a text file, an additional dialog appears, the Custom File Options Dialog. For information on printing, refer to Printing a Sheet from Spread Designer.

    The following image shows the File menu.

    The menu options are explained in the table below.

    Menu Option Description
    Open This offers a dialog box for browsing to a file to open. Only XML and XLS files are valid.
    Open Recent This dialog to the right of the Open option offers a drop-down of recently opened files that can be opened.
    Save This saves the file. If the file was previously specified and saved, this simply saves to that file. If the design has never been saved, the Designer offers a dialog box for saving the file with an option for specifying the file type.
    Save As This offers a dialog box for saving the file with a new name, or for saving the file to a new file type.
    Apply Apply and Exit This applies the changes done in the Spread Designer to the FpSpread component on the Form in the development environment. If Spread Designer is run stand-alone, apart from the development environment, these choices are not available.
    New This resets all values to their default values and clears the data area of any data.
    Revert This reverts the FpSpread component back to the values in the FpSpread component on the on the Form in the development environment. If Spread Designer is run stand-alone, apart from the development environment, these choices are not available.
    Preview This opens a separate window with a preview of the FpSpread component. The data area of the Spread Designer is grayed out and the preview window has focus.
    Print (see Page Layout menu) This opens a printer setup dialog to allow you to change any of the options on the default printer before printing the appearance of the data area of the design.
    Print Preview This opens a separate window to allow you to see the design according to how it prints when sent to the printer.
    Print This does not display a dialog and simply sends the design to the default printer.
    Print PDF This prints (saves) the file to PDF.
    Clear Recent Files List (History File List) With this preference selected, the list of recent files is cleared and the File menu adjusts accordingly, removing the Open Recent from its list of choices.
    Exit Click on the Exit button to exit the designer and return to the spreadsheet.
    Properties This opens a workbook properties dialog to allow you to store and display essential information of the workbook. For more information, refer to Storing Excel Summary and View.