Spread Windows Forms 13.0 Product Documentation
Spread Windows Forms 13.0 Product Documentation / Spread Designer Guide / Spread Designer User Interface / Spread Designer Menus / Insert Menu
In This Topic
    Insert Menu
    In This Topic

    The Insert menu can be used to add special characters, shapes, sparklines, tables, camera shapes, or charts. The Text section contains Symbol and WordArt options. Symbol is used to add special characters such as copyright symbols, unicode characters, and so on to a cell. WordArt is for creating a shape that has text. The chart section is for adding a chart control to the Spread control.

    Insert Menu

    Inserting Shapes and Camera Shapes

    The easiest way to design shapes on top of the spreadsheet is to use the Spread Designer Insert menu. The Drawing Tools menu is displayed after you create a shape using the Insert menu option. The Insert menu option is used to create various types of shapes. The Insert menu provides a quick way to draw shapes on the spreadsheet using the drawing space. The Drawing Tools menu contains several drawing-related icons for setting the color, line thickness, location, scale, and orientation.

    Select a block of cells and then select the Camera Shape icon to create a camera shape. The camera shape can include other shapes. Use the Drawing Tools menu to customize the image. The BackColor and ForeColor options under the DrawingTools menu do not apply to the camera shape. In general, properties that apply to the interior of the shape, do not apply to the camera shape.

    For more information on shapes in general and the drawing space, refer to Designing Shapes.

    The following figure identifies the items in the Insert and Drawing Tools menus:

    Drawing Toolbar Items

    The Shapes option in the Insert menu allows you to select one of the built-in shapes. The Shape Style section of the Drawing Tools menu allows you to set colors, outlines, and shadows.

    The Symbol option in the Insert menu allows you to put special characters in a cell (such as unicode characters).

    The Insert menu provides additional functions summarized in the table below.

    Item Description
    Table This allows you to add a table.
    Symbol This allows you to add special characters.
    Word Art This allows you to create a text based shape.
    Picture This allows you to add an image from a file.
    Shapes This allows you to select from a list of built-in (automatic) shapes. For a description of the built-in shapes, refer to Designing Shapes.
    Annotation Mode This allows you to draw a free-hand shape.
    Chart section This allows you to create a chart.
    Delete This allows you to delete a shape.
    Sparklines This allows you to add a sparkline.
    Camera Shape This allows you to add a camera shape.

    The Drawing Tools menu provides the following functions:

    Item Description
    BackColor This allows you to set the backcolor of the built-in shape.
    ForeColor This allows you to set the forecolor of the built-in shape.
    OutLineColor This allows you to set the outline color for the shape.
    Thickness This allows you to set the size of the outline for the shape.
    OutLineStyle This allows you to set the outline style for the shape.
    DropShadow This allows you to specify a shadow for the shape.
    Bring To Front or Send To Back This allows you to customize the order of shapes which can be on top of each other. Move shapes to the front or back of other shapes.
    Rotate This allows you to select typical amounts of rotation for a shape.
    Flip This allows you to flip a shape either horizontally or vertically.
    Scale This allows you to resize a shape proportionally by selecting a scaling factor.
    Set Picture This allows you to select an image and the image properties for a built-in shape.
    Clear Picture This allows you to remove an image from a built-in shape.
    Nudge The arrows to the right side of the Drawing Tools menu allow you to move the shape.

    You can right-click on a shape and select Properties from the menu to bring up the Shape Properties dialog.

    Inserting Charts

    The Insert menu is also used to create chart controls. Select a chart from the chart section of the Insert menu. This brings up the Chart Tools toolbar. You can change the chart type, select data, switch rows and columns, move the chart, or allow the user to move or resize the chart.

    Drawing Toolbar Items

    The change chart type changes from the 2D to the 3D view.

    The Move with Cells option will move the chart so that it stays with the original location (anchor) when you add or insert columns or rows in front of the chart control. The Resize with Cells option will resize the chart control if you resize columns or rows under the chart.

    Inserting Sparklines

    The Insert menu also has options for creating sparklines in cells.

    Insert Sparklines

    The Sparkline menu is displayed after you choose a sparkline type in the Insert menu. You can use the Sparkline menu to set options such as marker colors and axis settings for the sparkline.

    Sparklines Menu

    Inserting Tables

    You can use the Insert menu to add tables. Select data in the data area and then select Table from the Tables section. The TableTools menu is displayed and allows you to set options for the table such as name, size, and style.