Open a DESIGN in VS 19 ISSUES

Posted by: sylvain.rochette on 13 May 2020, 2:48 am EST

  • Posted 13 May 2020, 2:48 am EST

    Each time I open a report from VISUAL STUDIOS 19 in DESIGN since I installed AR14, it build my entire solution each time for absolutly nothing.

    So I end up waiting 2 min or more each time when I open a report.

    Can you deactivate that, or they are something to do because it's pathetic waiting 2 min, our solution is big. and waiting 2 min for nothing each time is not really good

  • Replied 14 May 2020, 12:02 am EST

    It's like impossible to work, it has been a day now wasting time in VS that NON STOP REBUILD EVERYTHING FOR NOTHING while switching from REPORT TO another SECTION REPORT, AS SOON I MODIFY THE CODE BEHIND, I SWITCH BANG REBUIL AUTO

    PLEASE HELP!
  • Replied 14 May 2020, 12:36 am EST

    Hello,


    I am working on your case. I am trying to reproduce the issue at my end and will inform you once I get any conclusion on this.

    Thanks,
    Mohit
  • Replied 14 May 2020, 1:09 am EST

    ok thank you, I suppose its from AR14, not sure 100%, but still, for example, change the code behind a report, add a section, change the code in the section, as soon you go in the design, it rebuild, i dont know if VS have an option to disable this behavior, but i dont think it was doing that on AC13, if so, it was faster lol, because i wasted so much time last day because of the non-stop rebuild...
  • Replied 14 May 2020, 2:31 am EST

    Hello,

    I have checked multiple times but unable to reproduce the issue at my end: I have followed the below steps:
    1: Create a SectionReport code-based WinForm application
    2: Open the SectionReport designer
    3: Add some code in code behind of section report
    4: Reopen the SectionReport designer
    5: Add a section in the report
    6: Add some code in code behind of section report
    7: Reopen the SectionReport designer

    Could you please provide the stripped-down sample so that I can reproduce the issue at our end.

    Thanks,
    Mohit
  • Replied 14 May 2020, 2:47 am EST

    when you change the code behind it must be saved, if they are not saved,
    I have 1 report with 1 section, let say they are both open, modify the code from one and save. then just click on the already opened design. it will build.

    Our project is big, have like more then 100 reports and its a library not a winform. (.NET Framework 4.7.2)

    will see for making a demo but right now I dont have time to much work...
  • Replied 19 May 2020, 2:02 am EST

    Please see the attached gif where I tried to replicate the issue at my end as well following the steps you mentioned. Let me know if I missed any step.
    I've also attached the sample application which I used to try and replicate the issue. Since your project is big and can't possibly share it, you can modify the attached application to replicate the issue and send it back.

    Can you also try uninstalling and re-installing ActiveReports 14.

    Thanks

    ARClassLibrary1.zip
  • Replied 19 May 2020, 6:26 am EST

    I tried your demo, its still build,
    the more easy to debug it is:

    1. Show the output window (popup) so you can always see it
    2. Open the design report, double click, now watch the build....

    Sure its fast the project is empty but Imagine a solution with 40 projects.

    So it build all 40 projects for nothing. So a minute or 2 later it show up.

    I cannot open the demo you sent. Impossible de charger le type 'GrapeCity.ActiveReports.Tools.EmbeddedResourceManager' à partir de l'assembly 'GrapeCity.ActiveReports, Version=13.1.17688.0, Culture=neutral, PublicKeyToken=cc4967777c49a3ff'
    but still i see the compile before the error occur.

    So I cannot test the other rebuild bug, but still related to the first easy to replicate.
  • Replied 20 May 2020, 5:59 am EST

    Hello,

    Thanks for your patience. I am able to replicate the issue after saving the code behind,

    I have escalated the issue to our development team(AR-24445) and will inform you once I get any information from them.

    Sorry for the all inconvenience caused to you.

    Thanks,
    Mohit
  • Replied 19 May 2020, 11:08 pm EST

    cool really appreciated!
  • Marked as Answer

    Replied 9 July 2020, 9:34 pm EST

    Hello,

    I am glad that your issue is solved now. Could you please check with the latest installer:
    http://cdn.grapecity.com/ActiveReports/AR14/Hotfixes/ActiveReports-v14.1.20320.msi

    Thanks,
    Mohit
  • Replied 12 July 2020, 11:07 pm EST

    It seam to work after I updated the nuget package!

    Thank you!
Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels