Page Footer displays wrong page number on last page

Posted by: gemse64 on 4 August 2017, 6:19 am EST

  • Posted 4 August 2017, 6:19 am EST

    Hello,



    I want to display page numbers which refer to the group. Now I have the problem that if the last group contains more than one page, the last page of my report will always display the wrong number. In fact it is the same number as the page before : "Page 7 of 8" where it should be "Page 8 of 8". Only in the case that the last group only contains one page it will display the correct value.

    What do I have to do to make it show correctly?

    I attach the screenshot where the settings of that field can be seen.

    Thanks for any help

  • Replied 4 August 2017, 6:19 am EST

    Hello,
    It was an earlier reported issue, could you please confirm if you are using the latest build of Active Reports 2.0 (2.5.0.1321)?


    Thanks,
    Deepak Sharma
  • Replied 4 August 2017, 6:19 am EST

    Hello,

    actually I have the verson 2.5.0.1314.



    That's the latest version I could find on the donwload page.

    Where do I get the version 2.5.0.1321?



    Best regards

    Monika
  • Replied 4 August 2017, 6:19 am EST

    Hello Monika,

    You can download this build from our FTP site. If you have a standard edition serial number(DD-AR-20-XXXXXXX), you can use this build. If you have a professional edition serial number(DD-AP-20-XXXXXXX), you could use this build.

    Regards,
    Prantik
  • Replied 4 August 2017, 6:19 am EST

    Hello



    I have same problem with my report. As per above suggestion I verified with the latest version "2.5.0.1322" but instead of showing last page count it shows blank. So basically if it is a 8 page report, on the 7th page I see "Page 7 of 8", but on the 8th page nothing is displayed - its blank.



    I saw the case "16388 When adding page numbering for groups in a page footer section, the last page number could be wrong." and I was expecting this issue should be fixed in "2.5.0.1322".



    Please verify the issue.



    -Mak
  • Replied 4 August 2017, 6:19 am EST

    Hallo Mak,

    yes this bug that I had was fixed with version 2.5.0.1322

    My page total is displayed now correctly in the page footer. Maybe you have this page total in another section and other properties of the section might influence the visibility of this field?

    Best regards



    Monika
  • Replied 27 June 2019, 6:04 pm EST


    Hi All,
    Was this issue resolved. How to check the latest version of ActiveReport my project is using.
    For me it is showing as ActiveReport.4.3.0 is this the version number.

    And from where i can get the latest version.
  • Marked as Answer

    Replied 11 July 2019, 5:30 pm EST

    Hello,

    You can get the latest version i.e. ActiveReports 13 from the below mentioned link:
    https://www.grapecity.com/download/product-activereports
    Click on the "Get free trial" button under "ActiveReports Professional".

    Thanks,
    Esha
Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels