Issue with License

Posted by: maw07 on 22 August 2019, 12:46 am EST

  • Posted 22 August 2019, 12:46 am EST

    I'm a developer and we changed machines.

    The build of the project is WPF and old. I still have the executable and serial keys.

    When viewing the project, I get greeted with the nag screen. I activate the license and seems to have worked. I can build and debug and no sign of the nag.

    When I deploy and run it off another machine, that machine gets the nag.

    I've tried multiple ways to resolve this by running the C1ProjectUpdater and the License Creator. I get a new license file, but it doesn't seem to do the trick.

    Assistance would be helpful.
  • Marked as Answer

    Replied 22 August 2019, 8:09 pm EST

    Hello,

    To help you better, could you please share information about the following points:
    1. Is the nag screen occurring on all client machines? Or it a specific machine deploying on which, nag screen comes?
    2. The machine on which the application is deployed, was ComponentOne ever installed on that machine? Does it have an expired ComponentOne license or an active license valid till some specific version?

    If you get the nag screen on all your deployment machines, then it's an issue related to deployment. The license information might not have been correctly embedded in the executable.
    To resolve that, kindly ensure that the licenses.licx file has Build Action property set to 'EmbeddedResource' and Copy to Output Directory property to any value other than 'Do not copy'

    Best wishes,
    Ruchir
  • Replied 23 August 2019, 6:19 am EST

    Ruchir,
    I realized the issue was an expired license and we will have to either renew or move in another direction.

    Thank you for the reply.
  • Replied 26 August 2019, 3:37 pm EST

    Welcome. Please let us know, if you need any further assistance in any related matter.

    ~Ruchir
Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels