ComponentOne MVC Core Build Error

Posted by: hbethel on 1 March 2021, 9:49 am EST

  • Posted 1 March 2021, 9:49 am EST

    Hello Forum! I'm hoping someone out here can help.

    As of last Friday afternoon, I started to get the following error in my .net MVC Core project when I try to build:

    "https://cdn.grapecity.com/ComponentOne/LicenseActivation/EN/C1LicenseActivation.exe". The request was aborted: Could not create SSL/TLS secure channel"

    I can download the file from a browser (even tried the Visual Studio built-in browser). I tried several other things like re-registered the app key, deleted and reinstalled the nuget package.

    Thanks!
    Herbert Bethel
  • Replied 1 March 2021, 10:11 pm EST

    Hi Herbert,
    Could you please make sure that you are using the latest build 3.0.20203.297 in your project. And you have the license activated on your machine? And you have the latest build on your machine which you can update from the ComponentOne ControlPanel.
    Please make sure that you are able to access the link from your browser: https://cdn.grapecity.com/ComponentOne/LicenseActivation/EN/C1LicenseActivation.exe

    In case you are able to access the link from browser, you should be able to use the same from the Visual Studio by opening the VS in Admin mode.
    We tried to replicate the issue but we are unable to replicate the issue. Please refer to the attached sample for reference.

    Regards,
    Manish Gupta

    LifewellApps.zip
  • Marked as Answer

    Replied 3 March 2021, 1:41 am EST

    After working with Manish through a support ticket, we were able to resolve the issue. The new license manager app would not accept my serial number as it was in an older format. Manish provided a new key.

    We never figured out why the C1LicenseManager.exe download link started throwing an error during a build, and will remain a mystery. After activating the license using the new key, I simply removed the download command from the targets file.
Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels