Paste not work in spread 8 on windows10

Posted by: simile28 on 5 February 2021, 1:09 am EST

  • Posted 5 February 2021, 1:09 am EST


    I am trying spread 8 on vb6. I pasted a clipboard content to any cell of spread several times on windows 7 and windows 10.

    On windows 7, it succeeded. But on windows 10, it failed. Nothing appeared after pressing control v.

    Please help. Thanks John

  • Posted 5 February 2021, 2:00 am EST

    My code Private Sub Form_Load() gridset End Sub

    Private Sub gridset() gr.MaxRows = 14 gr.MaxCols = 2

    gr.UnitType = UnitTypeTwips gr.AppearanceStyle = AppearanceStyleEnhanced gr.Appearance = AppearanceFlat gr.BorderStyle = BorderStyleNone gr.CursorStyle = CursorStyleArrow gr.EditModePermanent = True 'edit mode gr.EditMode = True 'edit mode gr.ColsFrozen = 1 gr.AutoSize = False gr.UserResize = UserResizeColumns gr.TextTip = TextTipOff gr.SetActionKey 0, False, False, 0 'f2 gr.SetActionKey 1, False, False, 0 'f3 gr.SetActionKey 2, False, False, 0 'f4 gr.RowHeadersShow = False gr.NoBeep = True gr.ProcessTab = True gr.TabStop = False gr.MoveActiveOnFocus = True

    gr.Col = -1 gr.Row = 0 gr.TypeTextShadow = False gr.TypeTextShadowIn = False

    gr.FontName = “arial” gr.FontSize = 9 gr.FontBold = False gr.RowHeight(0) = 255 * 1.3 gr.TypeHAlign = TypeHAlignLeft gr.TypeVAlign = TypeVAlignCenter

    gr.Row = -1 gr.FontName = “arial” gr.FontSize = 9 gr.FontBold = False gr.RowHeight(-1) = 255 * 1.3 gr.Text = “”

    gr.Col = 1 gr.Row = -1 gr.CellType = CellTypeEdit gr.TypeHAlign = TypeHAlignLeft gr.TypeVAlign = TypeVAlignCenter gr.Lock = True

    gr.Row = 1 gr.Text = " Name" gr.Row = 2 gr.Text = " Password" gr.Row = 3 gr.Text = " Server" gr.Row = 4 gr.Text = " Port" gr.Row = 5 gr.Text = " Database" gr.Row = 6 gr.Text = " Backup directory" gr.Row = 7 gr.Text = " Backup file to be restored"

    gr.Col = 2 gr.Row = -1 gr.CellType = CellTypeEdit gr.TypeHAlign = TypeHAlignLeft gr.TypeVAlign = TypeVAlignCenter

    gr.SetActiveCell 2, 6

    gr.EditModeReplace = True

    End Sub

  • Posted 10 February 2021, 11:06 pm EST

    Hi John,

    I could not replicate the issue at my end. The copied text appears correctly on pasting. Please refer to the attached application demonstrating the same.

    Can you please modify it and share back so that I can reproduce the problem at my end and investigate further? Also, share the build version of Spread that you are using.


  • Posted 11 February 2021, 6:38 am EST


    I attached is the exe file. Please run it on windows 10. Type a text on one cell and copy it to clipboard. Then try paste many times to other cells.

    Of about 15 pastes, only one worked. Sometimes failed at all.

    Regards, John

  • Posted 11 February 2021, 6:45 am EST

    The exe file in zip not appear in this post

  • Posted 11 February 2021, 6:50 am EST

    I attached the exe file in zip. Once again

  • Posted 11 February 2021, 9:22 pm EST


    Please zip the exe and then try to upload here. It should work.


  • Posted 11 February 2021, 9:22 pm EST


    Please zip the exe and then try to upload here. It should work.


  • Posted 11 February 2021, 10:38 pm EST


    1. I clicked the box “Drag and drop attachments here. File size limit is 5 MB. Images and ZIPs only” below box “post reply”

    2. After clicked the file name, the box displayed the zip information ( 4.5KB But the check and cross buttons below it looked inactive. Maybe there is some thing wrong on this page.

    3. I continued to click post reply box

    Note : If the zip file doesn’t appear, please create the exe file yourself from the project. I found the problem on exe file. I did not try it on ide. I do not have vs6 installed on windows 10.

  • Posted 15 February 2021, 11:52 pm EST


    I verified the behavior on a Win 10 machine at my end. However, the paste works fine. I tried 15-20 times and the paste worked correctly in all instances.

    I compiled the application in Win 10 environment and also, tried by running the exe directly.

    Can you please share in which environment you are creating the exe for this application? What is the locale of the machine used? Any additional information provided to reproduce the issue at my end would be appreciated.

    Thanks, Pragati

  • Posted 16 February 2021, 2:28 am EST

    Hi, Thanks for the answer. Please tell me what information you need about my computer. The jpg file of my screen capture is a good note to read. But unfortunately there is a posting problem on your site.

    Regards John

  • Posted 16 February 2021, 10:01 pm EST

    Hi John,

    While I get the forum related issue looked into, can you please share your files at the location below: Dropbox - Submit files

    I will take them from here.


  • Posted 16 February 2021, 10:28 pm EST

    Hi, Please tell me what information you need about my computer to locate on Dropbox - Submit files Regards John

  • Posted 17 February 2021, 8:29 pm EST

    Hi John,

    Please share the exe and the jpg of the screen capture that you mentioned about.


  • Posted 18 February 2021, 12:32 am EST


    Strange ! Today I found 2 different results with the experiment a few days ago.

    On my pc, pasting works normally.

    On my laptop, I had to press control v two times to get the a result.

    I have uploaded the file. Jpg files about: windows sysinfo, location and running the exe.

    Regards Johns

  • Posted 19 February 2021, 12:55 am EST

    Hi, I have added several text boxes to the application.

    Experiment on laptop. Pasting problem occured on the spread. Paste worked normally on the text boxes.

    Experiment on pc. Paste worked normally on spread and text boxes.

    I have uploaded a new zip file.

    Regards, John

  • Posted 22 February 2021, 8:42 pm EST

    Hi John,

    Thanks for sharing the files. I tried changing some settings at my end and also tried replicating the behavior on few other machines with exactly the same environment as yours. However, it does not reproduce. The copy-paste works fine every time.

    I doubt the problem is specific to the laptop, in question. Does any other application (without Spread) work normally on this machine? Can you please try copying in a fresh VB6 application and see if the behavior is fine with controls other than Spread? This would help us in isolation of the problem.

    Thanks, Pragati

  • Posted 22 February 2021, 9:32 pm EST

    Hi John,

    To further work on this issue, I have created a case CAS-19890-T2K7Z6 in the private portal. You can access it from here: The benefits of your GrapeCity account...

    Please continue the case there in order to avoid any confusion further.


Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels