PrintHeader, PrintFooter Font Name /fn does not work.

Posted by: spd on 25 June 2019, 7:19 am EST

  • Posted 25 June 2019, 7:19 am EST

    I am using Spread 7.0 (fpspru70.0cx 7.0.0.49) and when I use the /fn"fontname" the font does not change. All other control chars seem to work such as /fz"16" and /fb1. I have tried several different font names.

    sp.PrintHeader = "/fn""Times New Roman""/fz""20""/fb1/fi0/fu1/fk0/fs1 Times New Roman"

    Font comes out at 20 Bold but seems to be MS Sans Serif (maybe Arial???)not Times New Roman

  • Replied 27 June 2019, 7:52 pm EST

    Hi,

    I tested this issue with Spread 7 and Spread 8 and found that font shows correctly. Please refer to the attached sample application and .xps file.


    Thanks,
    Deepak Sharma
    Spread7PrintHeaderFont.zipSpread7PrinteheaderCheck.zip
  • Replied 28 June 2019, 8:47 am EST

    I tried your code and still did not get Times New Roman. I added a PrintPreview and tried on a VM and both did not work. Are you using fpspru70.0cx 7.0.0.49? I have attached your edited project with print preview. The printout and preview show the same thing, Screen Shot attached.
    TestSPHead.zip
  • Replied 2 July 2019, 1:42 am EST

    Any update. Does the project (TestSPHead.zip) act the same on your system?
  • Replied 3 July 2019, 10:18 pm EST

    Hello,

    I tested it again with print preview and found it working absolutely fine at my end. Please refer to the attached image.

    The version of Spread 7 I have is 7.0.52. Please download the same from the link below:
    http://cdn.grapecity.com/SpreadCOM/s712232010.zip

    Thanks,
    Deepak Sharma
  • Replied 16 July 2019, 10:00 am EST

    Updated to 7.0.56 and we still get the same result. Did you use my version of the code? I have tried on 3 different PCs. Not sure what is going on?
  • Replied 16 July 2019, 10:43 pm EST

    Hello,

    I tested this issue on a Windows XP machine, VS6.0(VB6.0) and Spread v7.0.52.
    Could you please share your environment details?

    Thanks,
    Deepak Sharma
Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels