Error importing file to Designer

Posted by: stephen.young on 11 March 2020, 8:22 pm EST

  • Posted 11 March 2020, 8:22 pm EST

    Using SpreadJS Designer 13.0.4 I get the error "File is not exist" when trying to import any xlsx file. It does not matter on the file content. For example, I have created a brand new xlsx with a single line of text in cell A1 then tried to import and still get the error.

    Is this a known issue with a resolution?
  • Replied 12 March 2020, 4:51 pm EST

    Hi Steve,

    We are sorry but we are unable to replicate the issue at our end using the 13.0.4 designer. We tried with the following steps to replicate the issue:
    1). Open designer sample
    2). Click File tab
    2). Select Import -> Excel File -> "Import Excel File" option
    3). Select a file to import and click open
    Observation: File opens successfully

    Please let us know if there are any additional steps to replicate the issue, also could you please share a gif of the steps involved in replicating the issue?

    Regards
    Sharad
  • Replied 12 March 2020, 8:23 pm EST

    Hi Sharad,

    Thanks for your response. I have tested a few more scenarios and have narrowed down the issue. It only occurs when I am opening the file from a folder that is mapped to OneDrive or Office 365. If I open it from anywhere else on my local drive or from a folder on a network drive then it works.

    I've attached gif of the error anyway.

    Thanks,
    Steve
  • Replied 15 March 2020, 5:01 pm EST

    Hi Steve,

    I tested with the One Drive, but it is working fine on our end. Attached is the gif of our observation.

    Could you please share your system configuration so that we may test on a similar machine? Following are the configuration of my machine on which I tested the functionality:
    • OS: Windows 10 Pro 64-bit
    • Build: 17763
  • Replied 15 March 2020, 6:27 pm EST

    Hi,

    I am on Windows 10 Enterprise 64-bit, build 16299. I am logged in on a non-admin account.

    Thanks
  • Replied 17 March 2020, 4:44 pm EST

    Thank you for the additional info, we are able to replicate the issue on Windows 10 Enterprise and hence we have forwarded it to the concerned team for further investigation of the issue. The internal tracking ID for the issue is SJS-3866. We will let you know about any updates regarding the same.
  • Replied 10 September 2020, 4:23 am EST

    Hello @Stephen.young,

    The SpreadJS team has looked more into this issue and have found that this is a limitation of SpreadJS. The file listed on your machine from OneDrive is a link, not an actual file that SpreadJS can import.

    As this is a limitation, you would first need to open the file by Excel or load the file with OneDrive, and then the designer can open it.

    Let us know if you have any questions!
  • Replied 10 September 2020, 5:25 pm EST

    Hi,

    I understand what you are saying but the file I was trying to open was created locally and I had been working on it in Visual Studio locally so it was already downloaded.
  • Replied 11 September 2020, 1:39 am EST

    Hi,

    Thank you for the additional information. we've shared it with the dev team too.
Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels