Flexgrid 2.6.20102.558 nag screen problem

Posted by: spetrid on 7 May 2020, 2:19 am EST

  • Posted 7 May 2020, 2:19 am EST

    A client of mine is using a program of mine made with vb.net which uses the flexgrid version 2.6.20102.558.
    After of almost 2 years, without any changes or problems in the program, my client gets Evaluation copy nag screens when he starts the program.
    I can not replicate the problem in any of my pcs (Windows 10 1806,1903), but the client has this problem to all 3 pcs that the program is installed.
    Any ideas? (the client uses windows 10 1909)
  • Replied 7 May 2020, 5:52 pm EST

    Hi Stavros,

    Sorry for the inconvenience caused.
    I understand that there has been no change made from your end and the license entry of the control used in the application is correct and as follows:
    C1.Win.C1FlexGrid.C1FlexGrid, C1.Win.C1FlexGrid.2

    If everything is fine at your end (license is activated and the entry in the licenses.licx file is correct), the evaluation nag screen can appear on the client machine in case ComponentOne is installed on the same. There are chances that the version installed at their end and the one used in your application is different. Please make sure that the nag screen shows the version used in your application only.

    Otherwise, please ask the client to uninstall the product from his machine. And, he should not face the nag screen while running your application.

    Regards,
    Prabhat Sharma.
  • Replied 7 May 2020, 8:25 pm EST

    Thank you for your reply!
    Your assumption is correct. No changes were made from my end and the license is correct. The newest information i got is that my client uses my application in 4 pcs. Two of them have the nag screen problem and two don't.
    The installation on all pcs is the same and the flexgrid dll is included on the application folder rather than installed globally in the system. The question is, how an other software using ComponentOne dlls can affect my installation?
    One more point is that the nag screen reports the correct version of the dll, so the chance of the program using an other version of the dll from an other global installation is minimal.
  • Replied 11 May 2020, 5:37 pm EST

    Hi Stavros,

    >The installation on all pcs is the same and the flexgrid dll is included on the application folder rather than installed globally in the system. The question is, how other software using ComponentOne dlls can affect my installation?

    Yes, you are right, ideally, the installation of the application should not get affected by the installed ComponentOne on the same machine because dlls are included with the application and it refers to that only.
    And as your application is not changed so it should not happen.
    To help us further investigate on this please follow the below-given steps and share your observations:

    1: Create a simple project with FlexGrid.
    2: Run it on your machine and make sure that the nag screen does not appear.
    3: Install this application on the client machines where you are facing the nag screen issue.
    4: Please let us know whether the nag screen appears for this app or not at the client end.

    Note: In the meantime please ask your customer to re-install your application and let us know if the nag screen appears or not.

    Regards,
    Prabhat Sharma.
  • Replied 12 May 2020, 5:19 am EST

    The program is actually very simple, control wise. It has two ComponentOne flexgrids only and 4 kinds of common visual studio components (labels,buttons,date picker,radio buttons). I tried to add more ComponentOne components but then my client was getting more nag screens.(I got none).
  • Marked as Answer

    Replied 12 May 2020, 10:43 pm EST

    Hello,

    It is very strange and we understand that your application is working fine on some client machines and just having the issue on some machines so to further investigate what possibly can cause the issue on the remaining machines, we need your sample project with your build(Bin/Debug) folder.

    Note: If you have any privacy concerns then you can share your application at our private channel: SupportOne by creating a case.
    http://supportone.componentone.com/

    Regards,
    Prabhat Sharma.
  • Replied 8 April 2021, 4:25 am EST

    One of my clients is having the same issue -- the TrueDBGrid nag is now appearing on an application that has been installed for a couple years.

    What was the resolution to this issue?
  • Replied 8 April 2021, 4:53 pm EST

    Hello John,

    As said in our previous response this issue can be occurred in the following case:

    If everything is fine at your end (license is activated and the entry in the licenses.licx file is correct), the evaluation nag screen can appear on the client machine in case ComponentOne is installed on the same. There are chances that the version installed at their end and the one used in your application is different. Please make sure that the nag screen shows the version used in your application only.

    If the issue still exists, please follow the below-given steps and share your observations:

    1: Create a simple project with TrueDBGrid.
    2: Run it on your machine and make sure that the nag screen does not appear.
    3: Install this application on the client machines where you are facing the nag screen issue.
    4: Please let us know whether the nag screen appears for this app or not at the client end.

    Note: In the meantime please ask your customer to re-install your application and let us know if the nag screen appears or not.

    Regards,
    Prabhat Sharma.
Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels