Glitching when resizing a themed C1Ribbon form

Posted by: mike on 11 October 2019, 5:17 am EST

  • Posted 11 October 2019, 5:17 am EST

    The window is themed with C1ThemeController. This does not happen very often, so it is hard to repeat. But it did happen a few times to me. This happens on startup, so there is no particular action that triggers it. In the video I am attaching you can see it happen as I resize the window.

    If I switch the theme away from Black (and even if I switch it back to Black afterwards) the glitch goes away.

    Do you have any suggestion about how I can fix this?

    Video: https://youtu.be/szhhUnjcvgo
  • Replied 11 October 2019, 5:19 am EST

    https://youtu.be/szhhUnjcvgo - a clickable link to the video.
  • Replied 13 October 2019, 7:45 pm EST

    Hello,

    We too can observe the issue in using C1ThemeController with Ribbon form so we have escalated this case to the developers. [Internal Tracking ID : 401720]

    We will let you know once we get any update on this from the deves end.

    Regards,
    Prabhat Sharma.
  • Replied 16 October 2019, 2:33 pm EST

    For our release planning purposes, any ETA on this fix at all?
  • Replied 16 October 2019, 8:38 pm EST

    Hello,

    We have asked the developers for the ETA, will let you know once we get any update on this.

    Regards,
    Prabhat Sharma.
  • Replied 16 October 2019, 10:12 pm EST

    Hello,

    We are happy to inform you that we have got the response from the developers and as per the developers ETA is 2019V3 hotfix.

    Regards,
    Prabhat Sharma.
  • Replied 8 December 2019, 6:48 am EST

    We installed the latest (4.0.20193.393) and ran it. The glitch is still there.

    Here is the video of it: https://youtu.be/reSpFukADJk

    It doesn't only happen when resizing. Sometimes it happens as the data in the window is updating. As you can see in the video, it only happens to some windows, not others - even if it is the same window class exactly.
  • Replied 8 December 2019, 5:07 pm EST

    Hi,

    The issue is not fixed in 2019V3 release. The fix will be available in the next hotfix and we will update the thread once it get released.

    Regards,
    Prabhat Sharma.
  • Replied 9 December 2019, 6:55 am EST

    For our planning purposes, can you give me an approximate release date for the hotfix?
  • Replied 9 December 2019, 4:00 pm EST

    Hello,

    We are asking the developers for the release date of 2019V3 hotfix and will let you know once we get any updates from them.

    Regards,
    Prabhat Sharma.
  • Replied 11 January 2020, 12:01 pm EST

    ... any idea when approximately this will come?
  • Replied 12 January 2020, 7:10 pm EST

    Hello Mike,

    The issue has been fixed in 20193.398 hotfix builds. You can download the builds from the following link :
    http://prerelease.componentone.com/hotfixindex.html

    Regards,
    Prabhat Sharma.
  • Replied 14 January 2020, 2:41 am EST

    I checked. Our issue is definitely NOT fixed. Still happening randomly on some windows. Same as before.
  • Replied 14 January 2020, 9:48 pm EST

    Hello,

    Sorry but we could not replicate the issue at our end with the 398 build version.
    Please find the 2 GIF in the attachment which shows the difference in the behavior with 398 and 393 build version.

    I am testing this with the WordPad product sample which is located in your machine at the given location :
    \Documents\ComponentOne Samples\WinForms\v4.0\C1Ribbon\CS\WordPad

    If you are using some other sample then please share the stripped down version of the sample replicating the issue and a GIF showing all the steps taken by you to replicate the issue.

    Regards,
    Prabhat Sharma.
    demoTheme.zip
  • Replied 15 January 2020, 7:04 am EST

    Recreating is a problem. It randomly happens within our app. Could open 20 windows with no problem or could have a couple have the issue. I attached a short video showing the issue when it does happen. NOTE: when the window is screwed up, can quickly tell because of white background around it, you see a white corner. Any time caption or anything with window changes, it flashes the blue theme.
    Once the window has the problem, it will continue until I close and re-open the window.

    Will try to get a small sample, but not hopeful. If you want, maybe give me a "test" version of the dlls that has a "LogNow" Method - I can then run our app and when the issue us recreated, make it call the LogNow menthod and you guys can log whatever you need to help narrow down the issue?C1ThemeFlashing.zip
  • Marked as Answer

    Replied 15 January 2020, 7:44 pm EST

    Hello,

    Your case has been replied on SupportOne on the given link :
    http://supportone.componentone.com/casedetail/417273

    Kindly continue this thread there only.

    Regards,
    Prabhat Sharma.
Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels