flexgrid globalization

Posted by: kisar on 8 July 2020, 9:27 pm EST

  • Posted 8 July 2020, 9:27 pm EST

    Hi
    i'm using flexgrid to view and edit
    I noticed that it does not use the actual globalization settings

    as example
    Binding="{Binding amount_invoice, StringFormat='N2'}"
    Shows 1999,00 instead of 1999.00
    (the dotnet databgrid shows correct the actual settings)


    I need to update the component in some way?

    Thanx
  • Replied 13 July 2020, 3:49 am EST

    Hi, somebody can help me to understand how to solve this basic problem.
    If I customize the globalization settings of the application (as example choosing "." for decimals) the flexgrid continue showing the default settings on the machine.
    Am I wrong?
    Is it possible solve this problem?
  • Marked as Answer

    Replied 13 July 2020, 7:06 pm EST

    Hi,

    Apologies for the delay in responding you as we missed out your case mistakenly.

    Regarding the issue that you are facing:
    StringFormat N2 shows the characters specific to the current culture. As you said you have changed the settings for showing "." for decimals. Therefore After changing the settings you also have to provide the current culture for ConverterCulture property of Binding.

    First add this xml namespace:
    xmlns:glob="clr-namespace:System.Globalization;assembly=mscorlib"

    And then while binding provide it as follows:
    <c1:Column Binding="{Binding amount_invoice, StringFormat=N2, ConverterCulture={x:Static glob:CultureInfo.CurrentCulture}}" Width="*"></c1:Column>


    Please refer to the same from the attached sample.

    Regards,
    Basant
  • Replied 13 July 2020, 7:08 pm EST

    Attachment:
    FlexGridStringFormat.zip
  • Replied 13 July 2020, 11:42 pm EST

    thanx
    it's perfect
Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels