Wijmo Supports Angular 10

We are happy to announce that Wijmo supports Angular 10! Wijmo has been supporting Angular since version 1 (AngularJS). We are committed to providing Angular developers a powerful toolset for building enterprise-grade applications. We are pleased to announce that you can start using Angular 10 applications with Wijmo today!

Wijmo offers a large set of fast and flexible Angular components, each with rich declarative markup. We have the best Angular DataGrid with features including sorting, grouping, searching, Excel-like filtering, DataMaps, custom CellTemplates, sparklines, rich editing, Excel/PDF export, validation, DetailRows, and more.

Get Started with Wijmo in Angular 10

To get started, you will need to install the Angular v10.0.0 release.

Then you can install Wijmo's angular components like so:

npm install @grapecity/wijmo.angular2.all

Warnings About CommonJS Imports

Starting with version 10, the Angular compiler will warn you when your build uses modules packaged in the CommonJS module format. Angular is urging developers to move to ECMAScript modules (ESM). Wijmo's default format is still CommonJS, so you will see a warning in Angular 10 about our modules. However, the Wijmo components will still function normally at runtime.

Wijmo has ESM modules, but we had to disable them in the past because they were not well supported (caused problems with the AOT compiler when used in the watch mode) in Angular 7 and 8. We know that our customers are using many versions of Angular, so we need to ensure we support more than just the latest version.

We are tuning our packages to get the best of both worlds. We hope to provide Wijmo packages that support ESM modules for Angular 10 while still maintaining CommonJS modules for older versions of Angular. Keep an eye out for this coming soon. But in the meantime, feel free to use Wijmo as-is in Angular 10.

Wijmo supports every version of Angular

Download the latest version of Wijmo

Download Now!