C1GridView VirtualScrolling row hight was fixed

Originally Posted 6 May 2014, 10:43 am EST

  • Originally Posted 6 May 2014, 10:43 am EST

    HI

    I know the C1GridView's VirtualScrolling functionality have some limitations,
    and I found the 'text wrapping' not works while VirtualScrolling = true :


    <wijmo:C1GridView ID="C1GridView2" runat="server" AutogenerateColumns="False" BorderStyle="None" BorderWidth="0px" Height="300px"
    AllowVirtualScrolling="True" PageSize="12" ScrollMode="Both" Width="400px">
    <CallbackSettings Action="Scrolling" />
    <Columns>
    <wijmo:C1TemplateField>
    <ItemTemplate>
    <%# Eval("Name") %>
     
    <a><%# Eval("Code") %> </a>
    </ItemTemplate>
    </wijmo:C1TemplateField>
    </Columns>
    <EmptyDataTemplate>
    (empty)
    </EmptyDataTemplate>
    </wijmo:C1GridView>


    VirtualScrolling = False :
    xxxxx
    yyy
    *yyy was word-wrapped(ok)

    VirtualScrolling = True :
    xxxxx
    *yyy was hidden(wrong)

    How can I makes the text wrapping works while virtual scrolling ? because the row height was fixed while VirtualScrolling = True.

    *
    <%# Eval("Name") %>
    not works too.

    Best regards

    Chris

  • Reply

    <div style="height: ...">< %# Eval("Name") %></div>

    not works too.
  • Reply

    Hello,

    The behaviour that you are currently observing is the design behaviour of C1GridView, where in the row height becomes fixed when virtual scrolling is enabled. Hence, the text in the cells is not wrapped when virtual scrolling is enabled.

    Unfortunately, there is no workaround for this issue currently. You would need to specify sufficient width for the columns so as to display the complete text in the cells.

    Hope it helps.

    Thanks,
    Manpreet Kaur
Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels