ReportsFolderPath (tempReports), permissions?

Posted by: haus on 10 September 2017, 11:40 am EST

  • Posted 10 September 2017, 11:40 am EST

    Hello, first off I apologize if this topic has been covered... this forum's search capabilities are lacking, and when a result is brought back, clicking on it just goes to the forum home page (FAIL).

    Anyway, I have my ReportViewer control setup on a page, and it works well. The first time someone "runs" the report, it creates a folder in ~/tempReports, 2D2816FE_EABAF6B9. The folder contains a file with the same name and a .c1d extension, a png preview and a zip file with the pages.

    If I re-run the report within a short amount of time, it works fine. The problem seems to be that if I try a longer amount of time later (like the next day), I get an error:

    Access to the path '2D2816FE_EABAF6B9.c1d' is denied.

    The folder (and files) still exists from the previous run(s). The tempReports folder already has ASP.NET Machine Account Modify permissions.

    What am I missing?

    Thanks,
    Dan
  • Replied 10 September 2017, 11:40 am EST

    Hello Richa, thanks for the reply.

    Since I posted the message, I worked around the error by setting .Cache.ShareBetweenSessions = False, which now that I'm aware of it should have been set anyway in my case. Now, it creates a new folder in tempReports as needed. However, the folders never get removed.

    I have now applied Authenticated Users with Modify permissions to the tempReports folder and the website folder. When/what triggers the temporary folders to get deleted?

    Thanks,
    Dan
  • Replied 10 September 2017, 11:40 am EST

    Hello Dan,

    The tempReports folders are created whenever any report is exported using the save button in the C1ReportViewer toolbar.

    However, there is no method to delete the temp folders. You would need to delete them manually.

    Thanks,
    Richa
  • Replied 10 September 2017, 11:40 am EST

    Hi Dan,

    My name is Mark and I work for ComponentOne on their web team. Can you give me an example of the type of search you are having issues with so I can try and re-create it.

    Also, please can you let me know, what browser you are using.

    Thanks

    --Mark
  • Replied 10 September 2017, 11:40 am EST

    Hello Dan,

    To resolve this, you have to give full permissions to “Authenticated user” the website folder and 'tempReports' folder. You can do that by performing following steps :
    1. Right click on the folder and select “Properties”.
    2. Click on “Security” tab.
    3. Click on “Edit…” button and add “Authenticated User” in list of users.
    4. Give full permissions to the user.
    5. Save the changes made.

    Also, try to run the VisualStudio as administrator if UAC is enabled.

    Please let me know whether this resolves your issue.

    Thanks,
    Richa
  • Replied 10 September 2017, 11:40 am EST

    @richas said:
    The tempReports folders are created whenever any report is exported using the save button in the C1ReportViewer toolbar.

    However, there is no method to delete the temp folders. You would need to delete them manually.


    Richa, thanks for the reply. This would be an extremely important feature to integrate into the next version of the tool if technically possible (I understand it may be easier said than done).

    @c1_markd said:
    My name is Mark and I work for ComponentOne on their web team. Can you give me an example of the type of search you are having issues with so I can try and re-create it.

    Also, please can you let me know, what browser you are using.


    Mark, I was just searching on words like "reportsfolderpath" and "tempreports". Any forum results that were returned, would redirect to the our.componentone.com home page when clicked. It still does it now. I am using FireFox 4 and Google toolbar plugin (I just won't let it go!)

    Thanks,
    Dan
  • Replied 10 September 2017, 11:40 am EST

    Thanks Dan. I can see what you are seeing. We will look into that now.
Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels