Active Reports generated pdf with overlapping lines

Posted by: athadakamalla on 8 November 2019, 5:36 am EST

  • Posted 8 November 2019, 5:36 am EST

    Hi,
    One of our pdf report generated using Active Reports started behaving differently(lines overlapping) since I deployed a new executable to production. The executable has the license information for Active Reports. It calls a different dll and generates the pdf report. There is nothing changed on the report that is causing the issue. And the problem is not seen with the older version of the executable.

    I believe there is something wrong with the way I'm building the executable. We haven't changed the executable in a while. My observation is that, I'm seeing a Red evaluation water mark on the development virtual machine where I'm building the executable. The water mark is not showing up on the production server, but the footer margin is expanded to the size of the water mark, which might be pushing the page content up and overlapping the lines.

    Any help is appreciated.

    I'm using the Active Report version 5.2.3.685
  • Replied 10 November 2019, 8:34 pm EST

    Hello,

    Sorry to mention that AR3 was declared a legacy product now. It is out of maintenance mode now. Hence, we do not provide support for the same or no bug fixing will be done in the same. I would recommend you use the latest version of ActiveReports i.e ActiveReports 13. Please refer to the following link for more information:
    https://www.grapecity.com/activereports.

    >>the problem is not seen with the older version of the executable.
    Are you using the same dll of ActiveReports in the older version of the executable or different?
    In my understanding, issue is not related to watermark. Could you please check after licensing the virtual machine.

    It is very helpful for us if you provide a stripped-down sample so that I can look into this.

    Thanks,



  • Replied 11 November 2019, 12:52 am EST

    Thanks Mohit for your reply. Unfortunately, my company is not willing to upgrade the Active Reports at this time. But I really appreciate your willingness to look into the issue. I'm attaching a old and new file generated off of the system. I'm also attaching a file generated from my development virtual machine. This shows the water mark.

    Yes I'm using the same Active Reports version in older executable.
  • Replied 12 November 2019, 4:26 pm EST

    Hello,

    It seems that files are not attached properly. Could you please attached the files in Zip format. Also please share the report layout with me.

    Thanks,
    Mohit
  • Replied 13 November 2019, 1:28 am EST

    ActiveReports Lines overlapping Issue.zip

    Please find the attached reports.
    Water mark issue on Development virtual machine.pdf: This is from our development virtual machine. We have a valid license but still shows the water mark.
    No Problem File with old build from profuction.pdf: This is from our production with a old build. No issues here.
    Problematic file with new build from production.pdf: This is from our production with a new build. You can see the lines overlapping. The water is not showing in the document but the footer margin is expanded with water mark size. I believe that is what is causing the page content pushed up and the lines are over lapping.

  • Replied 14 November 2019, 2:54 pm EST

    Hello Anil,

    It is very difficult to narrow down the issue with just an exported file. If you share the sample db and report file so that I can run the report at my end and replicate the issue at my end.

    >>We have a valid license but still shows the water mark.
    Could you please try to license the machine with the attached exe. If you have a professional license then, please use "LicensePro3.exe", if standard then, please use the "LicenseStd3.exe".

    Thanks,
    Mohit
    LicensePro3.zip
  • Replied 15 November 2019, 1:53 am EST

    I already have that executable for registering the license. We are using a standard license.
    It is not possible to send you the database and the application. I will have to create a sample report and try. In the mean time, please let me know if you have any sample application that I can use for testing. We have Visual studio 2015 with Active Reports3.

    I have an observation. The executable that I'm building was initially built on Visual studio 2010 with .Net frame work 3.0 and deployed to the production server sometime in 2015. There was no issue with the report till now. After that we never had changes in that executable. We have upgraded our development machines to 2015 and .Net frame work to 4.5. This is the first time we are building the executable on .Net frame work 4.5 and seeing the issue.

    Could you tell me if the ActiveReports3 is compatible with visual studio 2015 and .Net frame work 4.5?
  • Replied 15 November 2019, 3:54 am EST

    Hello,

    ActiveReports3 is never tested with VS2015 and 4.5 FW. It is not compatible with VS2015 and 4.5 FW
    Please refer to the following documentation link:
    https://help.grapecity.com/activereports/webhelp/Legacy/ARNET3/webframe.html

    Thanks,
    Mohit
  • Replied 15 November 2019, 6:22 am EST

    Thanks Mohit. But we have been using VS2015 and 4.5 FW for last 4 years and generating pdf reports. We haven't seen any issues so far. I would like to resolve the water mark issue on my dev virtual machine first. Could you tell me if there is any way to check if the license is registered properly in registries. When I run the license executable, i'm getting the successful confirmation message. I'm not sure why the water mark is still showing up even after successful confirmation message. Do I need to run the executable from a specific location(like application root folder?)
  • Replied 17 November 2019, 5:20 pm EST

    Hello Anil,

    >>But we have been using VS2015 and 4.5 FW for last 4 years and generating pdf reports
    Actually, It is never tested with VS2015 and 4.5 FW as it was not available at the time of AR3 release. So, we don't know how much AR3 compatible with this environment. Hence, we don't recommend to use AR3 with VS2015 and 4.5 FW.

    >>Do I need to run the executable from a specific location(like application root folder?)
    No, could you please share the environment of your virtual machine. As stated in the documentation, it only supports the following environment:
    Operating System: Windows® 2000, Windows® XP, Windows® NT 4.0, or Windows ™ Vista
    https://help.grapecity.com/activereports/webhelp/Legacy/ARNET3/ar3tbsHardwareandSoftwareRequirements.html

    Also, you can refer to the following documentation link for licensing information:
    https://help.grapecity.com/activereports/webhelp/Legacy/ARNET3/ar3tskLicensingReports.html

    Hope it helps.

    Thanks,
    Mohit
  • Replied 18 November 2019, 8:27 am EST

    I was able to remove the water mark by adding the license file into the console application that I am using to call the dll's. The lines are still overlapping though. I will try to fix them manually in Visual studio 2010 designer and use in Visual studio 2015. Could you tell me the pricing for upgrading to Active Reports newer version?
  • Marked as Answer

    Replied 18 November 2019, 4:38 pm EST

    Hello,
    >.Could you tell me the pricing for upgrading to Active Reports newer version?
    Please refer to the following link:
    https://www.grapecity.com/sales/activereports-renewals
    Also, you can contact our sales team for more detail at "us.sales@grapecity.com" or 18008582739(9AM - 5PM EST)

    FYI, the next major release of AR i.e AR14 is scheduled to release at the end of next month.

    Thanks,
    Mohit
Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels