Problem from switching from Win 7, 32 bit to 64 bit

Originally Posted 11 July 2013, 4:08 pm EST

  • Originally Posted 11 July 2013, 4:08 pm EST

    Hi,

    I have application in VB6 that works on the 32bit Win 7. I have transferring my project to the new computer with 64 bit Win 7. I installed in both computer the C1StudioActiveX-2012V3.
    I can load the project but when I run it I am getting the compiler error that can not find the project or library. It bring the reference for ComponentOne VSFlecGrid 8.0 (light).
    I looks at both computer (32 and 64) the differences are :

    OCX:
    in 32 is in Sysytem32
    in 64 is in SysWOW64

    the .oca file in 64 bit goes to VirtualStore dir. Itried to copy them to SysWOW64 but I still get the same error (compile error can't find project or library).

    I tried to register the OCX in the SysWOW64 follow by (regtlib msdatsrc.tlb) but that did not solve the problem either.

    what should i do?
    Regards,
    Razi
  • Reply

    HI,

    I'd suggest you to open your .vbp file in notepad and check for the line

    Object={1C0489F8-9EFD-423D-887A-315387F18C8F}#1.0#0; vsflex8l.ocx

    And try to register the file as given below

    http://our.componentone.com/groups/topic/windows-7-64bit-ocx-registration/

    Incase the issue persists, then create a new project and check if you can drag/drop and execute a project using VSFlexGrid.

    If yes, then open the .vbp file of the new project in Notepad and then replace the line above[regarding OBJECT] with the new line in your main project. Save it and open the project again

    Share your comments

    Regards,





Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels