CellType value does not print

Posted by: pshinohara on 8 September 2017, 12:38 pm EST

  • Posted 8 September 2017, 12:38 pm EST

    I created a custom celltype & it works fine in the spread.  When I print, I only see the graphical representation of the celltype & not it's data contents.


    Is there something obvious I am missing here?


    Thanks in advance.


     


     

  • Replied 8 September 2017, 12:38 pm EST

    Could you post a few screenshots of what is printing and what it should like.  There isn't anything obvious you are missing.  The contents of the cell should be printing.
  • Replied 8 September 2017, 12:38 pm EST

    Hello,


    When you print, the Graphics object passed into the PaintCell method is the printer's Graphic object. This will have a different scaling mode, so if you are doing any scaling in the PaintCell method of your custom celltype, you need to make sure you are doing it correctly for the printer.

  • Replied 8 September 2017, 12:38 pm EST

    Here is an attachment of the UI on the form.  When printed, I see the spread with the custom controls just as I see it on the form minus the custom control's contents.  So, the first control on the screen that has the contents of "Hepatitis B #2 (Adult)", shows up with that same control on the printout only the control shows no text value whatsoever.

  • Replied 8 September 2017, 12:38 pm EST

    Hello,


    Could you post a small zipped project reproducing this behavior for us to debug?

Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels