Possibly incorrect installation files for 05.00.2011?

Posted by: kober on 8 September 2017, 2:24 pm EST

  • Posted 8 September 2017, 2:24 pm EST

    Hi, I wanted to update to the latest version for a project in VS 2005, so I downloaded: spwin5_net20-2011.zip

    Spread for Windows Forms for 2.0 Framework (VS2005) 5      05.00.2011      7/15/2010

    After installing it, the version that appears in my VS 2005 toolbox is 5.0.2011.2008 .  Is it correct that it ends in 2008, instead of 2005?  http://www.fpoint.com/support/problems/spreadwin50.aspx seems to indicate it should end in 2005.

    The reason I ask is because if I drag that version of FpSpread from the toolbox to a form I get error messages "Invalid type (expected FarPoint.Win.Spread.FpSpread)   Parameter name: value", and it does not create the control.

    I assume Spread 5 is still supposed to work with Visual Studio 2005, since the download link includes "(VS2005)".  Is that correct?  Anything I'm doing wrong?

    Thanks,

    Kevin

  • Replied 8 September 2017, 2:24 pm EST

    Hi, I uninstalled 5.0.2011.2008, rebooted, reinstalled 5.0.2011.2008, and then opened VS 2005, and I still get the same error when I try to create a Spread control.  In the video I noticed you had several FpSpread items in your toolbox, but the video didn't show which version you used to create the Spread control.  Can you confirm that it was 5.0.2011.2008 that you had dragged onto the form, and also check that the reference for FarPoint.Win.Spread is 5.0.2011.2008 in that project?

     When I attempt to drag the Spread onto the form I get the error message three or four times, but it does successfully add the FarPoint references to the project.  Then the error appears every time I switch away from Design view.

  • Replied 8 September 2017, 2:24 pm EST

    I thought maybe the latest release just didn't work correctly, so I installed the older version 5.0.2005.2005 and set up the toolbox so only that version's items showed, and I get the same error when I try to create a Spread control in VS 2005.  Apparently Spread 5 just doesn't work for me in 2005, which is strange, since I've never had a problem like that with Spread.
  • Replied 8 September 2017, 2:24 pm EST

    Hello Kevin,

    If you look at the earlier installed Dlls, they are named as  "5.0.2005.2008". You should be able to use Spread 5.0.2011.2008 with VS2005.There is another version available to use with VS2008 which is "5.0.3511.2008"

    I have attached a video where I have used Spread 5.0.2011.2008 with VS2005. Please have a look.I would suggest you to run the installation again also check if you are able to add the DLL through "add reference"

     

     Thanks,


    2010/07/Spread5.0.2011.2008.rar
  • Replied 8 September 2017, 2:24 pm EST

    Hello,


    I am able to replicate the issue on my system with the same specifications and have forwarded it to the Project Development Team for the fix on the same.


    Will update you soon. Thanks.

  • Replied 8 September 2017, 2:24 pm EST

    Hello,


    Do you have v5.0.3505.2008 installed on your machine? If yes, then basically the problem only happens when you install both the .NET 3.5 and .NET 2.0 setups on the same machine, and only that particular release caused the problem -- it was fixed in subsequent releases.  That particular release caused problems with the .NET 2.0 releases since that one (including v5.0.2005.2008), so having v5.0.3505.2008 installed with break all of the .NET 2.0 releases from v5.0.2005.2008 wherein the policy assemblies for the design time assemblies cause the incorrect version of the control designer to be loaded by Visual Studio in design time.  Removing the release will remove those policy assemblies. 


    Since you are trying to update to the latest Spread v5, then the problem is caused by the v5.0.3505.2008 release(if it is installed).  Please remove it and see if it solves the problem. 


    We are currently testing a new setup for v5.0.3505.2008 with those policy assemblies removed; you can use that to reinstall the 3505 release without the problem assemblies if they need that particular version and then Spread v5.0.20xx can be used properly with v5.0.35xx on the same machine.


    Thanks.

  • Replied 8 September 2017, 2:24 pm EST

    Wow, great find!  I did have 5.0.3505.2008 installed, so I removed it and my problem with VS 2005 is fixed.  I have updated my 3.5 framework version to 5.0.3511.2008, and I no longer need 5.0.3505.2008, so I'm all set.  Thanks!!
Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels