Unable to use decimal point on French key board.

Posted by: anil143 on 8 September 2017, 2:24 pm EST

  • Posted 8 September 2017, 2:24 pm EST

    Hi ,

     

    We are using the below FarPoint controls in one of my project. We are facing some problems in the Spread controls as for French keyboard If user enters the "." key suing Numeric keyboard. It's entering nothing.

     

    Unable to use decimal point on key board.

     


    France's numbers appear as "1.234,98".  The numeric keypad has a full stop instead of a comma on it.  Normally in France, when you click on the full stop it will put in the decimal i.e. a comma.

     

    However in my application we are unable to use the full stop (because it is not a comma) on the numeric keyboard when entering in numbers.

     

    Could you please let us know the solution for this ASAP?

     

     

    FarPoint.CalcEngine                       : 2.5.2016.2005
    FarPoint.Excel.dll                           : 2.5.2016.2005   
    FarPoint.PluginCalendar.WinForms.dll : 2.5.2009.2005
    FarPoint.Win.dll                             :  2.5.2009.2005
    FarPoint.Win.Spread.dll                   : 2.5.2009.2005

     

    Thanks in advance

     

    Thanks,

    Anil

     
  • Replied 8 September 2017, 2:24 pm EST

    Thanks for the prompt reply.


    I can use the above code snippet for resolving the issue. But, diffrent region users are using my application like Germany,UK,France,Australia,Korea and Mexico.So, I can't do the custom code for the specifix users.


    Could you please let me know is this known issue in FarPoint grid control for that version?


    Any of the upgraded version is resolving this issue.. or still the problem is exist in new version also...


    Please let me know the solution for this  as it's impacting the productivity of the users.


    Thanks,


    Anil

  • Replied 8 September 2017, 2:24 pm EST

    Hello Anil,


    If you are trying to use the comma as your decimal separator in NumericCellType then you can use the DecimalSeparator of the NumericCellTypes and set it to ","



    FarPoint.Win.Spread.CellType.NumberCellType num1 = new FarPoint.Win.Spread.CellType.NumberCellType();
    num1.DecimalSeparator = ".";
    fpSpread1.ActiveSheet.Columns[0].CellType = num1;


    And in case you are trying to replace comma with fullStop in your text in Spread cells then you can use the String's replace method as given below:-



                string oldstring = fpSpread1.ActiveSheet.ActiveCell.Text;
                string newString = oldstring.Replace(",", ".");
                fpSpread1.ActiveSheet.ActiveCell.Text = newString;


    Hope this will help you. You can get back to us in case your requirement is something else and for further clarification.


    Thanks.

  • Replied 8 September 2017, 2:24 pm EST

    Hello Anil,


    This is giving us the same behavior in all the versions of Spread. However, as a workaround you can try determing the regional settings of the System and if in case it is French then you can apply a specific currency cell type with specific format. Please have a look at the code below:-



                FarPoint.Win.Spread.CellType.CurrencyCellType cur = new FarPoint.Win.Spread.CellType.CurrencyCellType();
                if (System.Globalization.CultureInfo.CurrentCulture.EnglishName.ToString() == "French (France)")
                {
                    cur.ShowSeparator = true;
                    cur.Separator = ".";
                    fpSpread1.ActiveSheet.Columns[2].CellType = cur;
                }


    Hope this will help you. Thanks.

  • Replied 8 September 2017, 2:24 pm EST

    Thanks for the update .


    I can use the above code snippet for France users.


    But here problem is, my application is deployed on Citrix. From Citrix, users will connect to my application from theire location (ex: Germany,Australia, France,Korea ,Austria,Mexico and UK). They will use theire regional langugae Keyboard and access this application. The above code should work only for France users. It might be affect to othet users also.


    Finally my application should work for all the users.


     Could you please help on this issue?


    Thanks,


    Anil


     

  • Replied 8 September 2017, 2:24 pm EST

    Hello Anil,


    We have escalated your issue to our Project Development Team for further investigation from there side on this issue. There response is awaited, will update you soon about the same.


    Thanks.

  • Replied 8 September 2017, 2:24 pm EST

    Hello Anil,


    We are not very familiar with how Citrix servers work, but I think it works like remote desktop, and the application runs on the server, not the client, so the regional settings of the client and the keyboard mappings in the device driver are not going to affect how the application runs on the server.


    Can you please share some more information about how Citrix servers work, and whether standard Windows programs like WordPad can see the regional settings of the client when run in the Citrix server.  For example, when you insert a date/time in Word Pad, does it show the formats for the client or server's regional settings?


    Thanks.

Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels